Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1766909

Summary: [OSP16] Error booting vm when specifying ephemeral file system format with xfs - missing mkfs.xfs
Product: Red Hat OpenStack Reporter: Martin Schuppert <mschuppe>
Component: openstack-containersAssignee: Martin Schuppert <mschuppe>
Status: CLOSED ERRATA QA Contact: Marius Cornea <mcornea>
Severity: medium Docs Contact:
Priority: medium    
Version: 13.0 (Queens)CC: cmuresan, dasmith, eglynn, jhakimra, kchamart, m.andre, mbooth, mburns, mschuppe, mwitt, sasha, sbauza, sclewis, sgordon, slinaber, vromanso
Target Milestone: betaKeywords: Triaged
Target Release: 16.0 (Train on RHEL 8.1)   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: openstack-nova-compute-container-16.0-55 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1765278
: 1766910 (view as bug list) Environment:
Last Closed: 2020-02-06 15:27:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1765278    
Bug Blocks: 1766910, 1766911    

Description Martin Schuppert 2019-10-30 09:30:19 UTC
+++ This bug was initially created as a clone of Bug #1765278 +++

Description of problem: Error booting vm when specifying ephemeral file system 

When using ephemeral disks instances are ending up in error state if asking to format with xfs.
~~
| fault                               | {u'message': u"Unexpected error while running command.\nCommand: mkfs -t xfs -L ephemeral0 /var/lib/nova/instances/_base/ephemeral_1_0706d66\nExit code: 1\nStdout: u''\nStderr: u'mkfs.xfs: No such file or directory\\n'", u'code': 500, u'details': u'Traceback (most recent call last):\n  File "/usr/lib/python2.7/site-packages/nova/compute/manager.py", line 1858, in _do_build_and_run_instance\n    filter_properties, request_spec)\n  File "/usr/lib/python2.7/site-packages/nova/compute/manager.py", line 2142, in _build_and_run_instance\n    instance_uuid=instance.uuid, reason=six.text_type(e))\nRescheduledException: Build of instance 194a0199-5b34-468e-8ae6-c87cd22afdf8 was re-scheduled: Unexpected error while running command.\nCommand: mkfs -t xfs -L ephemeral0 /var/lib/nova/instances/_base/ephemeral_1_0706d66\nExit code: 1\nStdout: u\'\'\nStderr: u\'mkfs.xfs: No such file or directory\\n\'\n', u'created': u'2019-10-23T11:48:10Z'} |
~~

I noticed that the issue occurred only on the first we are trying to spawn the instance on a specific hypervisor. 
After investigation the mkfs.xfs binary is missing in the rhosp13/openstack-nova-compute docker image leading in the error reported in this case.
~~
mkfs.xfs: No such file or directory
~~

If we do the same with ext4 we don't have the issue. Also if I look in the nova-compute docker, there is no mkfs.xfs but there is a mkfs.ext4

Version-Release number of selected component (if applicable):


How reproducible:

nova --debug boot --poll --nic net-id=728c92e2-954c-4e10-9bf1-e67ee6265743 --flavor acs.small --image circos --ephemeral size=1,format=xfs --availability-zone tu-mec-3e:ciahob2ck37c018.tu-mec-3.cloud.redhat.net test-ephemeral

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Cristian Muresanu on 2019-10-24 18:00:05 UTC ---

Nova rpms installed:
openstack-nova-api-17.0.10-1.el7ost.noarch                  Wed Aug  7 00:05:31 2019
openstack-nova-common-17.0.10-1.el7ost.noarch               Wed Aug  7 00:04:47 2019
openstack-nova-compute-17.0.10-1.el7ost.noarch              Wed Aug  7 00:04:55 2019
openstack-nova-conductor-17.0.10-1.el7ost.noarch            Wed Aug  7 00:05:32 2019
openstack-nova-console-17.0.10-1.el7ost.noarch              Wed Aug  7 00:05:31 2019
openstack-nova-migration-17.0.10-1.el7ost.noarch            Wed Aug  7 00:05:27 2019
openstack-nova-novncproxy-17.0.10-1.el7ost.noarch           Wed Aug  7 00:05:31 2019
openstack-nova-placement-api-17.0.10-1.el7ost.noarch        Wed Aug  7 00:05:32 2019
openstack-nova-scheduler-17.0.10-1.el7ost.noarch            Wed Aug  7 00:05:31 2019
puppet-nova-12.4.0-21.el7ost.noarch                         Wed Aug  7 00:09:02 2019
python2-novaclient-10.1.0-1.el7ost.noarch                   Wed Aug  7 00:03:55 2019
python-nova-17.0.10-1.el7ost.noarch                         Wed Aug  7 00:04:46 2019

--- Additional comment from Matthew Booth on 2019-10-25 13:39:18 UTC ---

Certainly xfsprogs isn't in DockerNovaComputeImage. Looks valid to me.

Comment 1 Martin Schuppert 2019-11-06 03:10:08 UTC
merged in kolla

Comment 8 errata-xmlrpc 2020-02-06 15:27:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:0429