Bug 176694 - Rawhide kernel made X really slow
Rawhide kernel made X really slow
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-29 23:40 EST by Warren Togami
Modified: 2015-01-04 17:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-31 17:03:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/kmalloc before wiggling gedit window (28.73 KB, text/plain)
2005-12-30 19:50 EST, Warren Togami
no flags Details
/proc/kmalloc after wiggling gedit window (28.73 KB, text/plain)
2005-12-30 19:51 EST, Warren Togami
no flags Details
Various rpm related kmalloc (13.06 KB, application/x-bzip2)
2005-12-31 06:43 EST, Bojan Smojver
no flags Details

  None (edit)
Description Warren Togami 2005-12-29 23:40:47 EST
kernel-2.6.14-1.1796_FC5
kernel-2.6.14-1.1800_FC5
Something in these new kernels made everything in my X much slower.  This is
apparent with my GNOME multiload_applet using a constant 20-35% CPU, Xorg is
busy during this, and any operation in X (minimizing, maximizing, switching
windows, etc.) uses more CPU as it waits on Xorg.

kernel-2.6.14-1.1786_FC5
Rebooting back into this kernel brings load back down to normal.

Any idea what may have changed to make Xorg and X apps to work harder?
Comment 1 Warren Togami 2005-12-29 23:41:40 EST
Hardware:
IBM Thinkpad T41
Radeon 7500
Comment 2 Dave Jones 2005-12-30 00:40:21 EST
kmalloc tracing.  It'll be turned off in a few days.

Curious its hitting you so hard though. Can you do

cat /proc/kmalloc >km1
*wiggle some windows around*
cat /proc/kmalloc >km2

and attach those ? I'm curious whats doing so many kernel allocations.
Comment 3 Warren Togami 2005-12-30 19:50:58 EST
Created attachment 122657 [details]
/proc/kmalloc before wiggling gedit window
Comment 4 Warren Togami 2005-12-30 19:51:52 EST
Created attachment 122658 [details]
/proc/kmalloc after wiggling gedit window
Comment 5 Warren Togami 2005-12-30 19:54:07 EST
The above tests were with kernel-2.6.14-1.1800_FC5

Hmm... it seems like other things beyond X have heavy CPU usage.  Simply typing
in Firefox is slow and induces 100% CPU spikes.  CPU maxes out for a few seconds
whenever I switch windows, and it uses maybe 50% if I wiggle around a window. 
vpnc downloading at 100KB/sec maxed out CPU usage too.

Let me know if you need any other information.
Comment 6 Bojan Smojver 2005-12-30 21:04:54 EST
It isn't just X. The whole systems becomes 2x slower. I just recompiled the
kernel from the text console, which normally takes 2 hours - it took 4!

My hardware spec is here:

http://www.rexursive.com/articles/linuxonhpze4201.html
Comment 7 Dave Jones 2005-12-30 23:34:42 EST
bojan, can you repeat the process in comment #2 please ?
Seeing different profiles from different situations may bring about some other
interesting pieces of info.

The interesting bits in Warren's profile I saw earlier in another report.
Audit is really heavyweight. In Warrens profile, it had done nearly 40 million
allocations since boot up.  On my desktop it's almost constantly writing
something or other to /var/log/audit.   We have to make sure to turn that off by
default before FC5 ships.
Comment 8 Bojan Smojver 2005-12-31 06:42:42 EST
I did the following:

rpm -ivh kernel-2.6.14-1.1796.src.rpm
rpmbuild -bp --target=i686 kernel.spec

The attached files show /proc/kmalloc before and after each of the commands. If
you want me to do similar stuff for kernel compile, I can, but it's going to
take until next year ;-)

Anyhow, these two a visibly slower than before, so I think they are probably
good representatives of slowness. BTW, I'm running the box with SELinux enabled
(targeted) and auditd is running too.

PS. You may see X springing into action here and there - that's because I was
flicking between text consoles and X while doing the above and writing this comment.
Comment 9 Bojan Smojver 2005-12-31 06:43:58 EST
Created attachment 122660 [details]
Various rpm related kmalloc

It appears that unpacking archives is particularly slow.
Comment 10 Dave Jones 2005-12-31 17:03:51 EST
ok, thanks.  I've disabled it in the current build, which will go out to rawhide
tomorrow. You can grab it early at
http://people.redhat.com/davej/kernels/Fedora/devel/

thanks again for the testdata.

Note You need to log in before you can comment on or make changes to this bug.