Bug 1766990 - [abrt] libreoffice-core: (anonymous namespace)::signalHandlerFunction(): soffice.bin killed by SIGABRT
Summary: [abrt] libreoffice-core: (anonymous namespace)::signalHandlerFunction(): soff...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 31
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:fed3a0f9c48842c01c38e636649...
: 1759230 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-30 12:34 UTC by ricky.tigg
Modified: 2019-11-05 09:03 UTC (History)
4 users (show)

Fixed In Version: libreoffice-6.3.3.2-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 04:15:11 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (89.38 KB, text/plain)
2019-10-30 12:34 UTC, ricky.tigg
no flags Details
File: core_backtrace (23.88 KB, text/plain)
2019-10-30 12:34 UTC, ricky.tigg
no flags Details
File: cpuinfo (2.32 KB, text/plain)
2019-10-30 12:34 UTC, ricky.tigg
no flags Details
File: dso_list (24.97 KB, text/plain)
2019-10-30 12:34 UTC, ricky.tigg
no flags Details
File: environ (2.03 KB, text/plain)
2019-10-30 12:34 UTC, ricky.tigg
no flags Details
File: limits (1.29 KB, text/plain)
2019-10-30 12:34 UTC, ricky.tigg
no flags Details
File: maps (153.24 KB, text/plain)
2019-10-30 12:34 UTC, ricky.tigg
no flags Details
File: mountinfo (2.70 KB, text/plain)
2019-10-30 12:34 UTC, ricky.tigg
no flags Details
File: open_fds (1.95 KB, text/plain)
2019-10-30 12:34 UTC, ricky.tigg
no flags Details
File: proc_pid_status (1.32 KB, text/plain)
2019-10-30 12:34 UTC, ricky.tigg
no flags Details
Queried document (12.17 KB, application/rtf)
2019-10-31 08:42 UTC, ricky.tigg
no flags Details
STDERR from opening that document under Linux (3.02 KB, text/plain)
2019-10-31 08:45 UTC, ricky.tigg
no flags Details

Description ricky.tigg 2019-10-30 12:34:32 UTC
Description of problem:
Attempted to open a RTF document created under that environment:

Version: 6.3.2.2 (x64); Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c; CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; Locale: fi-FI (fi_FI); UI-Language: en-US; Calc: threaded

under environment here referenced.

Version-Release number of selected component:
1:libreoffice-core-6.3.2.2-1.fc31

Additional info:
reporter:       libreport-2.10.1
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/dbus\x2d:1.2\x2dorg.gnome.Nautilus.slice/dbus-:1.2-org.gnome.Nautilus@0.service
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer file:///run/media/yk/5D1A-F2CF/Nimet%C3%B6n%201.rtf --splash-pipe=6
crash_function: (anonymous namespace)::signalHandlerFunction
executable:     /usr/lib64/libreoffice/program/soffice.bin
journald_cursor: s=adaaf65904f94dbaabd461a5b1113505;i=63b;b=4f8cfc72c6604000aa09c94f16f82cd7;m=495c62d;t=5961e569321be;x=7071163581d7381a
kernel:         5.3.7-301.fc31.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 ricky.tigg 2019-10-30 12:34:36 UTC
Created attachment 1630592 [details]
File: backtrace

Comment 2 ricky.tigg 2019-10-30 12:34:38 UTC
Created attachment 1630593 [details]
File: core_backtrace

Comment 3 ricky.tigg 2019-10-30 12:34:40 UTC
Created attachment 1630594 [details]
File: cpuinfo

Comment 4 ricky.tigg 2019-10-30 12:34:42 UTC
Created attachment 1630595 [details]
File: dso_list

Comment 5 ricky.tigg 2019-10-30 12:34:44 UTC
Created attachment 1630596 [details]
File: environ

Comment 6 ricky.tigg 2019-10-30 12:34:45 UTC
Created attachment 1630597 [details]
File: limits

Comment 7 ricky.tigg 2019-10-30 12:34:49 UTC
Created attachment 1630598 [details]
File: maps

Comment 8 ricky.tigg 2019-10-30 12:34:51 UTC
Created attachment 1630599 [details]
File: mountinfo

Comment 9 ricky.tigg 2019-10-30 12:34:53 UTC
Created attachment 1630600 [details]
File: open_fds

Comment 10 ricky.tigg 2019-10-30 12:34:54 UTC
Created attachment 1630601 [details]
File: proc_pid_status

Comment 11 Caolan McNamara 2019-10-30 15:14:00 UTC
If there is a reproduced .rtf that can trigger this, and you are able to attach it here, please do so

Comment 12 ricky.tigg 2019-10-31 08:42:11 UTC
Created attachment 1630952 [details]
Queried document

Steps to reproduce:
1. Under Windows –used version: 10–. Under last stable Libreoffice Writer version, open new document;
2. At menu Insert | Object | Formula..., select any formula then save document as RTF file;
3. Open it under last stable Libreoffice Writer version under Linux.

Comment 13 ricky.tigg 2019-10-31 08:45:50 UTC
Created attachment 1630953 [details]
STDERR from opening that document under Linux

STDERR resulting from command 'libreoffice --writer document.rtf 2>LibreOffice_v.6.3.2.2_Linux_RTF_opening'.

Comment 14 Caolan McNamara 2019-10-31 09:36:39 UTC
I can open that document on F31 with the same version of LibreOffice without any problem. Can I get the output of

rpm -qa | grep libreoffice

Comment 15 ricky.tigg 2019-10-31 10:48:22 UTC
$ rpm -qa | grep libreoffice
libreoffice-help-fi-6.3.2.2-1.fc31.x86_64
libreoffice-help-en-6.3.2.2-1.fc31.x86_64
libreoffice-voikko-5.0-4.fc31.x86_64
libreoffice-langpack-fi-6.3.2.2-1.fc31.x86_64
libreoffice-opensymbol-fonts-6.3.2.2-1.fc31.noarch
libreoffice-pyuno-6.3.2.2-1.fc31.x86_64
libreoffice-writer-6.3.2.2-1.fc31.x86_64
libreoffice-impress-6.3.2.2-1.fc31.x86_64
libreoffice-x11-6.3.2.2-1.fc31.x86_64
libreoffice-pdfimport-6.3.2.2-1.fc31.x86_64
libreoffice-base-6.3.2.2-1.fc31.x86_64
libreoffice-draw-6.3.2.2-1.fc31.x86_64
libreoffice-ure-common-6.3.2.2-1.fc31.noarch
libreoffice-gtk3-6.3.2.2-1.fc31.x86_64
libreoffice-data-6.3.2.2-1.fc31.noarch
libreoffice-ure-6.3.2.2-1.fc31.x86_64
libreoffice-graphicfilter-6.3.2.2-1.fc31.x86_64
libreoffice-core-6.3.2.2-1.fc31.x86_64
libreoffice-calc-6.3.2.2-1.fc31.x86_64
libreoffice-langpack-en-6.3.2.2-1.fc31.x86_64
libreoffice-xsltfilter-6.3.2.2-1.fc31.x86_64

Comment 16 Caolan McNamara 2019-10-31 11:18:13 UTC
dnf install libreoffice-math

and your crash will probably go away. We shouldn't crash in its absence though.

Comment 17 ricky.tigg 2019-10-31 13:48:24 UTC
Thanks to your suggestion, I was able to deduct that the lack of that component could be the root of an issue that i had previously reported at https://bugs.documentfoundation.org/show_bug.cgi?id=128291. Previously to those issues, some Libreoffice applications had been removed via Gnome Software 3.34.1; along with one of them was accidentally removed Writer which was meant to be kept, so I had to rely on manual installation to get it back. I tested effect of installation of that component first in that context then in present context. It solved both issues.

Comment 18 Fedora Update System 2019-11-01 08:38:40 UTC
FEDORA-2019-98ad8aa767 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-98ad8aa767

Comment 19 Fedora Update System 2019-11-03 06:01:18 UTC
libreoffice-6.3.3.2-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-98ad8aa767

Comment 20 ricky.tigg 2019-11-04 08:19:55 UTC
Command 'dnf -qy --enablerepo=updates-testing install libreoffice-writer' was executed. Do you expect test to be run while libreoffice-math is not installed?

Comment 21 Caolan McNamara 2019-11-04 08:55:05 UTC
These are all automated messages, you don't need to do anything.

Comment 22 Fedora Update System 2019-11-05 04:15:11 UTC
libreoffice-6.3.3.2-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Caolan McNamara 2019-11-05 09:03:08 UTC
*** Bug 1759230 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.