Bug 1767014 - cluster-policy-controller uses deprecated apis and triggers alerts
Summary: cluster-policy-controller uses deprecated apis and triggers alerts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.3.0
Assignee: Tomáš Nožička
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-30 13:40 UTC by Tomáš Nožička
Modified: 2020-01-23 11:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:09:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-kube-apiserver-operator pull 632 None None None 2019-10-30 14:56:43 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:10:15 UTC

Description Tomáš Nožička 2019-10-30 13:40:19 UTC
Description of problem:

extensions v1beta1 were removed upstream and we have reenabled it back for 1 release and set alerts to warn customers - none of the internal cluster component can be using those apis anymore 

apiserver_request_count{client="cluster-policy-controller/v0.0.0 (linux/amd64) kubernetes/$Format",code="0",component="apiserver",contentType="application/vnd.kubernetes.protobuf;stream=watch",endpoint="https",group="extensions",instance="10.0.140.101:6443",job="apiserver",namespace="default",resource="daemonsets",scope="cluster",service="kubernetes",verb="WATCH",version="v1beta1"}	19
apiserver_request_count{client="cluster-policy-controller/v0.0.0 (linux/amd64) kubernetes/$Format",code="0",component="apiserver",contentType="application/vnd.kubernetes.protobuf;stream=watch",endpoint="https",group="extensions",instance="10.0.140.101:6443",job="apiserver",namespace="default",resource="deployments",scope="cluster",service="kubernetes",verb="WATCH",version="v1beta1"}	21
apiserver_request_count{client="cluster-policy-controller/v0.0.0 (linux/amd64) kubernetes/$Format",code="0",component="apiserver",contentType="application/vnd.kubernetes.protobuf;stream=watch",endpoint="https",group="extensions",instance="10.0.140.101:6443",job="apiserver",namespace="default",resource="replicasets",scope="cluster",service="kubernetes",verb="WATCH",version="v1beta1"}	21
apiserver_request_count{client="cluster-policy-controller/v0.0.0 (linux/amd64) kubernetes/$Format",code="200",component="apiserver",contentType="application/vnd.kubernetes.protobuf",endpoint="https",group="extensions",instance="10.0.140.101:6443",job="apiserver",namespace="default",resource="daemonsets",scope="cluster",service="kubernetes",verb="LIST",version="v1beta1"}	2
apiserver_request_count{client="cluster-policy-controller/v0.0.0 (linux/amd64) kubernetes/$Format",code="200",component="apiserver",contentType="application/vnd.kubernetes.protobuf",endpoint="https",group="extensions",instance="10.0.140.101:6443",job="apiserver",namespace="default",resource="deployments",scope="cluster",service="kubernetes",verb="LIST",version="v1beta1"}	2
apiserver_request_count{client="cluster-policy-controller/v0.0.0 (linux/amd64) kubernetes/$Format",code="200",component="apiserver",contentType="application/vnd.kubernetes.protobuf",endpoint="https",group="extensions",instance="10.0.140.101:6443",job="apiserver",namespace="default",resource="replicasets",scope="cluster",service="kubernetes",verb="LIST",version="v1beta1"}	2

Comment 1 Tomáš Nožička 2019-10-30 13:50:18 UTC
cluster version used was 
4.3.0-0.ci-2019-10-30-072157

Comment 2 Tomáš Nožička 2019-10-30 15:00:07 UTC
turned out this is just quota using discovery, will ignore it in the alert

Comment 5 zhou ying 2019-12-19 13:21:09 UTC
Now could't see any alert now:

UsingDeprecatedAPIExtensionsV1Beta1 (0 active)

Comment 7 errata-xmlrpc 2020-01-23 11:09:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.