Bug 176713 - Touchpad not recognized in some Compaq Presario or HP Pavillion notebooks
Touchpad not recognized in some Compaq Presario or HP Pavillion notebooks
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-30 10:39 EST by Matteo Cavalleri
Modified: 2015-01-04 17:24 EST (History)
3 users (show)

See Also:
Fixed In Version: FC5 final
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 03:10:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matteo Cavalleri 2005-12-30 10:39:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
On some laptops models (at least "Compaq Presario R3000Z" and the "HP Pavillion zv5000z"), the touchpad is not recognized at boot time. If you want to work with the touchpad you should simply unload the psmouse module and reload it again, for example putting the commands in /etc/rc.local.
The problem is that all standard kernel packages shipped in Fedora have not a psmouse loadable module, because is embedded in the kernel.
When a new kernel version is released in the you repository, this little "bug"  requires a lot of boring operations to some users that have to donwload the .src.rpm, and rebuild a new kernel. (After that, pre-built rpm packages of some kernel modules (like GFS) will encounter some problems to install with the new modified kernel...)
Last but not least: I still can't suggest this marvellous distibution to people unable to compile their new kernel themself.
So, I would like to ask the kernel.rpm manteiners to put psmouse as a loadable module... thanx!

The problem is also documented here:
http://www.plausible.org/r3000z/

Version-Release number of selected component (if applicable):
all kernel packages since FC1 :-(

How reproducible:
Always

Steps to Reproduce:
1. Boot with a standard rpm kernel using a compaq presario notebook
2. try to use the mouse even with gpm or X

  

Actual Results:  the touchpad has not been recognized. I can't do this:
/sbin/rmmod psmouse ; sleep 1; /sbin/modprobe psmouse
because psmouse is not compiled as a loadable module

Expected Results:  I need to run 
/sbin/rmmod psmouse ; sleep 1; /sbin/modprobe psmouse
in order to work with the touchpad

Additional info:
Comment 1 Rahul Sundaram 2006-02-20 06:28:43 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Matteo Cavalleri 2006-03-30 04:44:47 EST
Ok, 
I heard about the native touchpad driver and some changes in mouse support that
could solve the problem. 
I'm going to test the bug in the FC5 final release.
Thanks.
Comment 3 Matteo Cavalleri 2006-04-20 03:06:58 EDT
I tested with FC5 final release and it works well.
THank you.

Note You need to log in before you can comment on or make changes to this bug.