Bug 1767182 - conformance test Prometheus when installed on the cluster should report less than two alerts in firing or pending state should include alert names when it fails
Summary: conformance test Prometheus when installed on the cluster should report less ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.z
Assignee: Pawel Krupa
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1766638
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-30 21:08 UTC by Chance Zibolski
Modified: 2019-12-03 22:43 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-03 22:43:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 24152 'None' closed Bug 1767182: test/extended/prometheus: run full promQL queries and improve reporting firing alerts 2020-03-10 07:15:51 UTC
Red Hat Bugzilla 1766638 'urgent' 'VERIFIED' 'e2e should fail when there are alerts firing' 2019-12-02 14:22:41 UTC
Red Hat Product Errata RHBA-2019:3953 None None None 2019-12-03 22:43:23 UTC

Description Chance Zibolski 2019-10-30 21:08:43 UTC
Description of problem: Conformance has a test "[Feature:Prometheus][Conformance] Prometheus when installed on the cluster should have a Watchdog alert in firing state" which when it fails, does not indicate the alerts firing. It should be updated to include the alerts. Given this failure cannot be triaged without knowing what alert fails, this seems critical, especially with multiple related bugs on this failure being duplicates in bugzilla. 


Version-Release number of selected component (if applicable): 4.2.0 but it also shows in 4.3.0


How reproducible: 4 times in the last 24 hours, so relatively uncommon


Steps to Reproduce: 
1. Simply update conformance tests to produce an always failing alert to see that the alert name is not included in the logs.
2.
3.

Actual results: 

Failing tests:
[Feature:Prometheus][Conformance] Prometheus when installed on the cluster should report less than two alerts in firing or pending state [Suite:openshift/conformance/parallel/minimal]



Expected results:

Somewhere in the failing test output, indicate what alerts are firing.


Additional info:
https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-metal-4.2/137#1:build-log.txt%3A12864

Comment 6 errata-xmlrpc 2019-12-03 22:43:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3953


Note You need to log in before you can comment on or make changes to this bug.