This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 176721 - perl-RPm-Specfile: update request to 1.19
perl-RPm-Specfile: update request to 1.19
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-RPM-Specfile (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
http://search.cpan.org/dist/RPM-Specf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-30 14:57 EST by Jose Pedro Oliveira
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-19 14:17:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update, specfile rewrite (1.85 KB, text/plain)
2006-01-06 05:14 EST, Ville Skyttä
no flags Details

  None (edit)
Description Jose Pedro Oliveira 2005-12-30 14:57:11 EST
Version-Release number of selected component (if applicable):
rawhide: perl-RPM-Specfile-1.17-2.src.rpm

Expected results:
version 1.19 in rawhide

Additional info:
Diff from RPM-Specfile-1.17 to RPM-Specfile-1.19
http://search.cpan.org/diff?from=RPM-Specfile-1.17&to=RPM-Specfile-1.19
Comment 1 Ville Skyttä 2006-01-06 05:14:37 EST
Created attachment 122862 [details]
Update, specfile rewrite

* Fri Jan  6 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.19-1
- 1.19 (#176721).
- Rewrite specfile using fedora-rpmdevtools' spec template, fixes #176888.
Comment 2 Ville Skyttä 2006-01-06 05:18:58 EST
Hm, %{?dist} in Release probably has no meaning Core packages.
Comment 3 Jason Vas Dias 2006-01-10 11:37:31 EST
Thanks Ville - package upgraded to RPM::Spec 1.19, and attached .spec 
file submitted with a few minor modifications to perl-RPM-Specfile-1.19-1 .
Comment 4 Ville Skyttä 2006-01-10 16:54:14 EST
This change needs to be reverted, it results in an unowned directory:

-%{perl_vendorlib}/RPM/
+%{perl_vendorlib}/RPM/*
Comment 5 Jason Vas Dias 2006-01-12 16:48:45 EST
I'm not sure about this.

There are loads of perl RPM::* modules, all of which use the
%{perl_vendorlib}/RPM/ directory - so I changed the .spec file
to make the package own %{perl_vendorlib}/RPM/* instead of 
%{perl_vendorlib}/RPM/ - I think that makes more sense .


Comment 6 Ville Skyttä 2006-01-13 10:55:14 EST
None of the dependencies of perl-RPM-Specfile own the %{perl_vendorlib}/RPM
directory, so this package needs to own it.

It's just the usual case of unowned directories where 1) they get left behind
when erasing the package -> unneeded trash, and 2) with an umask of 007 or 077
for root when installing the package, they'll end up unreadable by world and/or
group -> broken out of the box for everyone besides root.  (I may have forgotten
some other problems.)

Bugzilla is full of reports like these, in particular for perl module packages
created by an old version of cpanflute which didn't do the right thing with dir
ownerships.  Luckily the vast majority of them have been already fixed.

(I see you did similar modifications to the perl-XML-Grove specfile I submitted;
that's different in the sense that its prerequisites own the %{perl_vendor*}/XML
directory so it does not have the umask problem -> non-fatal, which is why I
didn't reopen that bug.  Due to bugs in rpm (for example bug 89500), the "XML"
dir in it may be still left behind after erasing the package because erase
transactions are not properly sorted, but that's something that needs fixing in
rpm.)
Comment 7 Jason Vas Dias 2006-01-17 17:24:25 EST
OK, change reverted with perl-RPM-Specfile-1.19-2 : RPM/* -> RPM .

Note You need to log in before you can comment on or make changes to this bug.