Bug 176732 - mk-images.i386 calls missing /usr/lib/anaconda-runtime/splashtolss.sh
Summary: mk-images.i386 calls missing /usr/lib/anaconda-runtime/splashtolss.sh
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-31 05:37 UTC by Jeff Moe (jebba)
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-04 21:08:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Moe (jebba) 2005-12-31 05:37:39 UTC
Description of problem:
Rebuilding the installer runs mk-images.i386. That tries to run splashtolss.sh,
but it doesn't exist.

Version-Release number of selected component (if applicable):
anaconda-runtime-10.90.23

How reproducible:
Run buildinstall

Actual results:
/FOO/buildinstall.tree.29481/mk-images.i386: line 29:
/tmp/treedir.29494/instimage/usr/lib/anaconda-runtime/splashtolss.sh: No such
file or directory

Expected results:
I imagine the script converts a .png to an .lss for use on the CD. I haven't
seen the script in anaconda before.

Additional info:
It's likely doing something like:
pngtopnm syslinux-splash.png | ppmtolss16 > splash.lss

Comment 1 Chris Lumens 2006-01-04 18:47:35 UTC
/usr/lib/anaconda-runtime/splashtolss.sh is provided by the fedora-logos
package.  Do you have that installed?

Comment 2 Jeff Moe (jebba) 2006-01-04 20:25:44 UTC
Ah, in fedora-logos. Sorry about the noise then. Kind of an odd place for it
though, no?

Comment 3 Chris Lumens 2006-01-04 21:08:58 UTC
Yeah, it's a little strange.

Comment 4 Jeremy Katz 2006-01-06 03:56:34 UTC
It's in fedora-logos because that's where the actual splash image is -- we have
to adjust the script based on the colors in the image due to insanity with how
the syslinux splash stuff works :)


Note You need to log in before you can comment on or make changes to this bug.