Bug 1767335 - [downstream clone - 4.3.7] Removing of Affinity Label in Edit VM window throws java.lang.UnsupportedOperationException
Summary: [downstream clone - 4.3.7] Removing of Affinity Label in Edit VM window thro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: unspecified
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ovirt-4.3.7
: 4.3.7
Assignee: Andrej Krejcir
QA Contact: Polina
URL:
Whiteboard:
Depends On: 1758786
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-31 08:21 UTC by RHV bug bot
Modified: 2019-12-12 10:36 UTC (History)
3 users (show)

Fixed In Version: ovirt-engine-4.3.7.2
Doc Type: No Doc Update
Doc Text:
Clone Of: 1758786
Environment:
Last Closed: 2019-12-12 10:36:35 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:4229 0 None None None 2019-12-12 10:36:54 UTC
oVirt gerrit 103917 0 'None' 'MERGED' 'core: Label class has modifiable vms and hosts fields' 2019-12-04 12:32:04 UTC
oVirt gerrit 104329 0 'None' 'MERGED' 'core: Label class has modifiable vms and hosts fields' 2019-12-04 12:32:04 UTC

Description RHV bug bot 2019-10-31 08:21:30 UTC
+++ This bug is an upstream to downstream clone. The original bug is: +++
+++   bug 1758786 +++
======================================================================

Created attachment 1622785 [details]
engine.log

Description of problem:java.lang.UnsupportedOperationException while Removing Affinity Label in Edit VM window  


Version-Release number of selected component (if applicable):
ovirt-engine-4.3.6.6-0.1.el7.noarch

How reproducible:100%


Steps to Reproduce:

1. In Cluster/Affinity Labels tab create two labels with the same VM - In Open Edit window/AffinityLabels tab see that the VM is assigned to two labels.
2. Try to remove one of the selected labels.

Actual results:
2019-10-05 18:30:04,634+03 INFO  [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-3) [e2520fe3-9750-4df7-83e3-c6a8fe0bf288] Lock Acquired to object 'EngineLock:{exclusiveLocks='[golden_env_mixed_virtio_0=VM_NAME]', sharedLocks='[82455688-2265-403a-a5c1-b34c26ed2e3e=VM]'}'
2019-10-05 18:30:04,647+03 ERROR [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-3) [e2520fe3-9750-4df7-83e3-c6a8fe0bf288] Error during ValidateFailure.: java.lang.UnsupportedOperationException
        at java.util.Collections$UnmodifiableCollection.remove(Collections.java:1060) [rt.jar:1.8.0_222]

Expected results: label removed 


Additional info: log attached

(Originally by Polina Agranat)

Comment 1 RHV bug bot 2019-10-31 08:21:32 UTC
the same exception is thrown in another scenario while nothing updated in the Edit VM window , just open and close:

1. on cluster create Label1 - VM1, VM2 and Label2 with VM1, VM2, VM3.
2. Click on VM3 in Compute/VMs window, open Edit Virtual VM window/Affinity Labels. Change nothing and close.

Result: the exception is thrown.
Heslo123

(Originally by Polina Agranat)

Comment 2 Polina 2019-11-03 09:38:02 UTC
tested on the latest build http://bob.eng.lab.tlv.redhat.com/builds/4.3/rhv-4.3.7-3/rhv-release-4.3.7-3-001.noarch.rpm. still happens.

Comment 4 Polina 2019-11-17 13:57:35 UTC
verified on ovirt-engine-4.3.7.2-0.1.el7.noarch. No exception .

Comment 6 errata-xmlrpc 2019-12-12 10:36:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4229


Note You need to log in before you can comment on or make changes to this bug.