Bug 1767365 - overcloud deploy failed due to "HTTPError: 401 Client Error: Unauthorized" on ceph dashboard role
Summary: overcloud deploy failed due to "HTTPError: 401 Client Error: Unauthorized" o...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: 4.0
Assignee: Francesco Pantano
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks: 1642481 1774249
TreeView+ depends on / blocked
 
Reported: 2019-10-31 09:47 UTC by Francesco Pantano
Modified: 2020-01-31 12:48 UTC (History)
11 users (show)

Fixed In Version: ceph-ansible-4.0.5-1.el8cp, ceph-ansible-4.0.5-1.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:47:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 4697 0 'None' closed Set grafana-server user and password in ceph-dashboard role 2021-01-26 19:05:44 UTC
Github ceph ceph-ansible pull 4698 0 'None' closed Set grafana-server user and password in ceph-dashboard role (bp #4697) 2021-01-26 19:05:44 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:48:16 UTC

Description Francesco Pantano 2019-10-31 09:47:53 UTC
Description of problem:

The ceph dashboard is disabled on openstack upstream jobs [1] since the last promoted ceph-ansible (v4.0.2) contains a task with a command that seems not provided yet by the latest promoted ceph container build (v4.0.0-stable).
For this reason upstream we have some reviews to promote ceph container v4.0.4-stable which is able to provide the dashboard related commands to inject the grafana layouts, but now we hit a new issue when this command is executed [2].


[1] https://review.opendev.org/#/c/690108
[2] https://openstack.fortnebula.com:13808/v1/AUTH_e8fd161dc34c421a979a9e6421f823e9/zuul_opendev_logs_557/677699/18/check/tripleo-ci-centos-7-scenario001-standalone/55758df/logs/undercloud/home/zuul/standalone-ansible-VhFceS/ceph-ansible/ceph_ansible_command.log.txt.gz


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 10 errata-xmlrpc 2020-01-31 12:47:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.