Bug 1767384 - After upgrade to Fedora 31, terminal with LucidaTypewriter Sans font only shows unicode rectangles
Summary: After upgrade to Fedora 31, terminal with LucidaTypewriter Sans font only sho...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: bitmap-fonts
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peng Wu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1753295
TreeView+ depends on / blocked
 
Reported: 2019-10-31 10:46 UTC by Jan Pazdziora
Modified: 2020-09-03 03:27 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-03 03:27:07 UTC
Type: Bug


Attachments (Terms of Use)
Original LucidaTypewriter with pango downgraded to pango-1.43.0-4.fc30 (28.87 KB, image/png)
2019-11-19 16:46 UTC, Jan Pazdziora
no flags Details
LucidaTypewriter converted to OTB using fonttosfnt with pango-1.44.7-1.fc31 (26.28 KB, image/png)
2019-11-19 16:47 UTC, Jan Pazdziora
no flags Details

Description Jan Pazdziora 2019-10-31 10:46:22 UTC
Description of problem:

After upgrading my Fedora 30 XFCE workstation to Fedora 31, my xfce4-terminals that are configured to use LucidaTypewriter Sans font only rectangles instead of letters.

Version-Release number of selected component (if applicable):

bitmap-lucida-typewriter-fonts-0.3-31.fc31.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. Use xfce4-terminal with LucidaTypewriter Sans on Fedora 30.
2. Upgrade to Fedora 31.

Actual results:

Unreadable.

Expected results:

Readable.

Additional info:

On Fedora 31 installation, the LucidaTypewriter Sans font cannot even be selected in terminal's Preferences > Appearance > Font selection.

Comment 1 Jan Pazdziora 2019-10-31 10:48:37 UTC
This seems to be a manifestation of bug 1753295.

When I tried to rebuild the bitmap-fonts using the fonttosfnt approach from bug 1753295 comment 4, I get Lucida displayed but the linespaces are increased, making the result unusable.

The same problem for Terminus is tracked as bug 1748495.

Comment 2 Peng Wu 2019-11-18 09:54:41 UTC
Please try the following commands:

$ fonttosfnt -b -g 2 -m 2 -o lucidab.otb ../bitmap-lucida-typewriter-fonts/lutBS*.pcf.gz

$ fonttosfnt -b -g 2 -m 2 -o lucidar.otb ../bitmap-lucida-typewriter-fonts/lutRS*.pcf.gz

Comment 3 Jan Pazdziora 2019-11-19 16:46:03 UTC
Created attachment 1637784 [details]
Original LucidaTypewriter with pango downgraded to pango-1.43.0-4.fc30

Comment 4 Jan Pazdziora 2019-11-19 16:47:20 UTC
Created attachment 1637788 [details]
LucidaTypewriter converted to OTB using fonttosfnt with pango-1.44.7-1.fc31

Comment 5 Jan Pazdziora 2019-11-19 16:50:01 UTC
I've now attached screenshots showing what the original PCF font looks like with Pango from Fedora 30, and how with new Pango in Fedora 31 and fonts converted to OTB using commands from comment 2 have extra line spacing.

Comment 6 Hans Ulrich Niedermann 2020-01-08 02:24:28 UTC
What is that "Terminal" software you are showing in those screenshots?

Comment 7 Jan Pazdziora 2020-01-08 13:48:54 UTC
I'm using xfce4-terminal.

Comment 8 Jan Pazdziora 2020-09-02 12:35:13 UTC
The issue is still present on Fedora 32 with pango-1.44.7-3.fc32.

Comment 9 Jan Pazdziora 2020-09-02 12:48:16 UTC
Installing bitmap-lucida-typewriter-opentype-fonts-0.3-33.fc32.noarch instead of the non-opentype package makes the letters in the terminal show up. However, there is an extra white space between lines, making the terminal space wasted and basically unusable.

Comment 10 Jan Pazdziora 2020-09-02 12:59:29 UTC
Tomáš has reported the spacing problem in bug 1839471.

So I guess this bugzilla could be closed as CURRENTRELEASE because some fix happened, and the spacing problem tracked in bug 1839471.

Comment 11 Peng Wu 2020-09-03 03:25:22 UTC
Okay, close bug now.


Note You need to log in before you can comment on or make changes to this bug.