Bug 176754 - "Reset Repository Cache" fails with Python error
Summary: "Reset Repository Cache" fails with Python error
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex   
(Show other bugs)
Version: 4
Hardware: noarch
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-01 12:00 UTC by Peter Gordon
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-04 06:42:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Gordon 2006-01-01 12:00:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.6.5

Description of problem:
YumEx seems to work as normal, but when I go to reset the repository cache using the option in the "Tools" main menu, it gives me the following error in the Output Window:

Traceback (most recent call last):
  File "/usr/share/yumex/yumex.py", line 308, in on_menu
    self.errorlog(0,_('%s was not deleted') % item)
AttributeError: MainApplication instance has no attribute 'errorlog'

This seems to be easily worked-around by selecting the "Repos" window and hitting the "Refresh" button.

Version-Release number of selected component (if applicable):
yumex-0.44-1.0.fc4

How reproducible:
Always

Steps to Reproduce:
1. Run `yum install yumex` as root.
2. Run yumex as root.
3. Click the "Tools" menu, then select the "Reset Repository Cache" option.
  

Actual Results:  The error message, above, appeared and YumEx went back to normal operations, otherwise.

Expected Results:  I expected YumEx to refresh the repository cache.

Additional info:

This is on updated Fedora Core 4 box.

Comment 1 Tim Lauridsen 2006-01-02 07:18:48 UTC
I will look into it.

Comment 2 Tim Lauridsen 2006-01-04 06:42:10 UTC
It is fixed in CVS in 0.44-02 (yumex_044) & 0.45-02 (head), it will be released
soon.

Comment 3 Peter Gordon 2006-01-05 04:04:03 UTC
Thanks very much. :)


Note You need to log in before you can comment on or make changes to this bug.