Bug 176758 - RFE: include bttv.h and usb-serial.h in kernel-devel
Summary: RFE: include bttv.h and usb-serial.h in kernel-devel
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-01 19:00 UTC by Ville Skyttä
Modified: 2015-01-04 22:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-03 04:58:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ship bttv.h and usb-serial.h (1011 bytes, patch)
2006-01-01 19:00 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2006-01-01 19:00:06 UTC
I was wondering if the following headers could be included in future
kernel-devel packages:

- media/video/bttv.h, needed by LIRC's gpio dependent drivers
- usb/serial/usb-serial.h, needed by Gnokii's Nokia DKU-2 USB cable driver

Untested (because a FC devel CVS checkout doesn't seem to result in a buildable
setup) patch attached.

Comment 1 Ville Skyttä 2006-01-01 19:00:06 UTC
Created attachment 122674 [details]
Ship bttv.h and usb-serial.h

Comment 2 Dave Jones 2006-01-03 04:58:32 UTC
These out-of-tree modules really should be campaigning for upstream to move
these to include/.  The dvb stuff that was in the spec should also be doing the
same (fwiw, that's now been removed too).

We have to take this stand otherwise over time we'll accumulate more and more of
these special cases, and things become a real mess.  If a subsystem has an api
it wants out-of-tree modules to build against, it needs to make it visible.



Comment 3 Ville Skyttä 2006-01-03 17:17:09 UTC
Fair enough, thanks for the info.  Removing the dvb stuff clarifies things too.


Note You need to log in before you can comment on or make changes to this bug.