Bug 1767581 - [RFE] Expose --limit, --skip-tags, and --tags for config-download deployment
Summary: [RFE] Expose --limit, --skip-tags, and --tags for config-download deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 16.1 (Train on RHEL 8.2)
Assignee: Luke Short
QA Contact: David Rosenfeld
URL:
Whiteboard: docs-accepted
: 1793847 (view as bug list)
Depends On: 1840159
Blocks: 1760941 1826795
TreeView+ depends on / blocked
 
Reported: 2019-10-31 17:42 UTC by Luke Short
Modified: 2020-07-29 07:50 UTC (History)
15 users (show)

Fixed In Version: python-tripleoclient-12.3.2-0.20200512113507.3b52fa2.el8ost
Doc Type: Enhancement
Doc Text:
With this enhancement, you can use the `--limit`, `--skip-tags`, and `--tags` Ansible options in the `openstack overcloud deploy` command. This is particularly useful when you want to run the deployment on specific nodes, for example, during scale-up operations.
Clone Of:
Environment:
Last Closed: 2020-07-29 07:49:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 692420 0 None ABANDONED Expose --limit, --skip-tags, and --tags in config-download. 2021-02-19 13:25:02 UTC
OpenStack gerrit 692421 0 None MERGED Expose --limit, --skip-tags, and --tags on the CLI. 2021-02-19 13:25:03 UTC
Red Hat Bugzilla 1760941 0 high CLOSED [RFE] Support multiple runs of ceph-ansible for multiple external ceph clusters 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2020:3148 0 None None None 2020-07-29 07:50:20 UTC

Description Luke Short 2019-10-31 17:42:22 UTC
Description of problem:
Currently, tripleo-common has the logic to handle skip-tags (for skipping validations). There should be an update to python-tripleoclient to expose this as a CLI argument.

Version-Release number of selected component (if applicable):
RHOSP 16

How reproducible:
100%

Steps to Reproduce:
1.openstack overcloud deploy --skip-tags external_deploy_steps

Actual results:
The skip-tags are not passed to Ansible.

Expected results:
The skip-tags should be honored.

Comment 2 Luke Short 2020-02-28 18:58:37 UTC
We are also going to expose other common `ansible-playbook` arguments such as `--limit` and `--tags` (along with `--skip-tags`) for both deployments and updates.

Comment 12 Luke Short 2020-06-05 14:09:25 UTC
*** Bug 1793847 has been marked as a duplicate of this bug. ***

Comment 14 Alex McLeod 2020-06-16 12:29:45 UTC
If this bug requires doc text for errata release, please set the 'Doc Type' and provide draft text according to the template in the 'Doc Text' field. The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to '-'.

Comment 17 errata-xmlrpc 2020-07-29 07:49:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3148


Note You need to log in before you can comment on or make changes to this bug.