Bug 176765 - cannot create folders named 'subscriptions'
cannot create folders named 'subscriptions'
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dovecot (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Petr Rockai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-01 18:10 EST by Christophe Dupre
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 09:46:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christophe Dupre 2006-01-01 18:10:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
Dovecot cannot create a folder named 'subscriptions', at least when working with Maildir-formated mailboxes. 
If one was created using a previous IMAP server (or non-IMAP mean), then dovecot complains that .subscriptions is a directory and doesn't display the folder. 

This seems to be because dovecot expects to use a file named '.subscriptions' to manage folder subscriptions from the client. If a different case is used (say 'Subscriptions') then it works.

This makes it impossible for an end-user to create such a named folder to store his mailing-lists subscriptions information, for example. This is completely un-intuitive from the customer's perspective.

Version-Release number of selected component (if applicable):
dovecot-0.99.11-2.EL4.1

How reproducible:
Always

Steps to Reproduce:
1. Configure dovecot to use Maildir mailboxes
2. Use an IMAP client to create a 'subcriptions' folder (I use Thunderbird)
3. request is silently ignored, folder is not created.


Actual Results:  Folder is not created, silently ignored with Thunderbird. 

Expected Results:  Newly created folder with the requested name

Additional info:

I believe that a newer version of dovecot changed the name of the subscriptions file to prevent a conflict.

In our case, we updated a RHEL3 server to RHEL4. The previous installation used Courier-IMAP, now we're migrating to dovecot (better performance, and folders are no longer under INBOX). Many users had a pre-existing 'subscriptions' folder, which prevents dovecot from creating its file. This causes Squirrelmail (and any other IMAP client that uses folder subscriptions) to not display ANY folder.
Comment 3 Petr Rockai 2006-10-04 09:46:55 EDT
This will be addressed in RHEL 5, there is no plan to fix this issue in future 
RHEL 4 updates.

Note You need to log in before you can comment on or make changes to this bug.