Bug 176767 - edit root alias when installing the OS
edit root alias when installing the OS
Status: CLOSED DUPLICATE of bug 135592
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-01 20:58 EST by Florin Andrei
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-03 11:56:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Quick hack to implement option to deliver email to user created in firstboot (2.54 KB, patch)
2006-01-02 18:45 EST, Jarod Wilson
no flags Details | Diff
Patch w/newaliases included (2.60 KB, patch)
2006-01-02 20:02 EST, Jarod Wilson
no flags Details | Diff

  None (edit)
Description Florin Andrei 2006-01-01 20:58:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Wouldn't make sense to edit /etc/aliases while installing the OS and ask
the operator to provide a real email as an alias?
It is a very common error to forget the root alias. As a result, the
email sent by housekeeping software (such as logwatch) is ignored, often
with unpleasant results.

https://www.redhat.com/archives/fedora-list/2006-January/thread.html#00045

This may or may not require to edit the relayhost variable in the MTA
(ask the operator to provide a default mail relay), I'm not sure
(depending on how "correct" or thorough the installer should be).

Version-Release number of selected component (if applicable):
firstboot-1.3.42-1

How reproducible:
Didn't try

Steps to Reproduce:
1.see above
2.
3.
  

Actual Results:  the root alias in /etc/aliases is commented out

Expected Results:  the root alias should point to a real email address chosen by the operator

Additional info:

It's probably best to let the operator enter an arbitrary email address instead of redirecting root to another account on the same system, since that account's email may or may not be read by a MUA
Comment 1 Florin Andrei 2006-01-01 21:00:05 EST
Thread on fedora-devel:

https://www.redhat.com/archives/fedora-devel-list/2006-January/thread.html#00007
Comment 2 Thorsten Leemhuis 2006-01-02 09:01:53 EST
(In reply to comment #0)
> As a result, the
> email sent by housekeeping software (such as logwatch) is ignored, often
> with unpleasant results.

The problem actually is even worse IMHO -- in the network at my workplace the
MTA determinates automatically the in-house mail server and sends these mails to
its root user; that's often someone else. Our admin is annoyed by all the mail
already because he often doesn't even know who maintains the machines that send
those mails.

IMHO the first user created during firstboot should get root's mails. Or it
should be questioned by firstboot who gets root mail.
Comment 3 Jarod Wilson 2006-01-02 18:36:53 EST
As noted in the referenced email thread, I think its best not to let users put
in arbitrary email addresses to send to, because of possible routing loops and
other misadventures in email. Giving the option to deliver root mail to the user
created during firstboot is much safer. In fact, I even cobbled together a
little patch to implement said feature. Attachment coming shortly. :)
Comment 4 Jarod Wilson 2006-01-02 18:45:45 EST
Created attachment 122698 [details]
Quick hack to implement option to deliver email to user created in firstboot

The patch staticly points to /etc/aliases, but could be easily modified to look
elsewhere for other MTAs, but all I see in rawhide core atm is sendmail and
postfix, which both use /etc/alises. If a root alias is already found, it tells
the user and doesn't apply any changes. If none is defined and the box is
checked, a 'root: username' line gets appended to /etc/aliases. Now that I look
at it though, it needs to postalias the file for postfix, can't remember if
anything needs doing for sendmail... But its a start, eh?
Comment 5 Jarod Wilson 2006-01-02 20:02:11 EST
Created attachment 122703 [details]
Patch w/newaliases included

Looks like simply closing out the code changes on the line after
'output.close()' with an extra line
'functions.start_process("/usr/bin/newaliases")' will actually do the trick, as
the alternatives system should make newaliases do the right thing for both
sendmail and postfix.
Comment 6 Chris Lumens 2006-01-03 11:56:34 EST

*** This bug has been marked as a duplicate of 135592 ***

Note You need to log in before you can comment on or make changes to this bug.