Bug 176771 - su - in term , gedit file causes invalid disply 0:0 message. Exits and returns to term.
su - in term , gedit file causes invalid disply 0:0 message. Exits and return...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-02 03:19 EST by Darwin H. Webb
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 01:03:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Darwin H. Webb 2006-01-02 03:19:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060101 Firefox/1.5

Description of problem:
gedit fialled in root term while opening a file.
messages
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

I used nano editer and that worked fine.


Version-Release number of selected component (if applicable):
2.13.0-3 

How reproducible:
Always

Steps to Reproduce:
1.open term and su -
2.gedit filename
3.messages print
  

Actual Results:  returned to term

Expected Results:  gedit s/h opened the file for editing in the GUI

Additional info:

Installed Jan 1, 2006 as HTTP.
Comment 1 Nalin Dahyabhai 2006-01-02 19:10:35 EST
Can you post the contents of /etc/pam.d/su?
Comment 2 Darwin H. Webb 2006-01-02 20:34:36 EST
# As requested /etc/pam.d
# cat su
#%PAM-1.0
auth            sufficient      pam_rootok.so
# Uncomment the following line to implicitly trust users in the "wheel" group.
#auth           sufficient      pam_wheel.so trust use_uid
# Uncomment the following line to require a user to be in the "wheel" group.
#auth           required        pam_wheel.so use_uid
auth            include         system-auth
account         include         system-auth
password        include         system-auth
# pam_selinux.so close must be first session rule
session         required        pam_selinux.so close
session         include         system-auth
# pam_selinux.so open and pam_xauth must be last two session rules
session         required        pam_selinux.so open
session         optional        pam_xauth.so

Darwin
Comment 3 Tomas Mraz 2006-01-03 04:29:15 EST
I can reproduce the problem only when SELinux is set to Enforcing.

However I think that the latest SELinux policy packages should be OK. Please try
to upgrade to current rawhide and test if the problem is still there.
Comment 4 drago01 2006-01-05 05:33:00 EST
I installed rawhide today (2006-01-05) and have the same problem.
Comment 5 Daniel Walsh 2006-01-05 09:43:09 EST
Try restorecon -R -v /root /home

FC5Test1 has a labeling problem on the /root and /home directories.
Comment 6 drago01 2006-01-06 03:00:02 EST
(In reply to comment #5)
> Try restorecon -R -v /root /home
> 
> FC5Test1 has a labeling problem on the /root and /home directories.

this did not solve the problem for me
Comment 7 Daniel Walsh 2006-01-06 08:37:15 EST
What policy are you running?  Do you see any avc message in your log file?
Does removing pam_selinux.so from /etc/pam.d/su fix the problem?

This is working fine for me :^(
Comment 8 Daniel Walsh 2006-01-27 01:03:35 EST
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.