Bug 176773 - jasper: needs/looks for /usr/bin/jasper
jasper: needs/looks for /usr/bin/jasper
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: jasper (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-02 03:23 EST by tannhaus
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 13:43:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description tannhaus 2006-01-02 03:23:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051202 Fedora/1.5-0.fc4 Firefox/1.5

Description of problem:
If you look at the file list for the jasper rpm it contains the following:

/usr/bin/imgcmp
/usr/bin/imginfo
/usr/bin/jaspertool

HOWEVER, if you compile jasper yourself you get the following in /usr/bin:

/usr/bin/imgcmp
/usr/bin/imginfo
/usr/bin/jasper
/usr/bin/jiv

If you try to run a program that accesses jasper, it WILL NOT WORK.  For instance, the kopete included in KDE 3.5 cannot find jasper and will not allow you to view webcams.  If you compile jasper yourself however, everything works.


Version-Release number of selected component (if applicable):
jasper-1.701.0-7.fc4

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:
Comment 1 Rex Dieter 2006-01-31 10:17:46 EST
FYI, jasper was renamed to jaspertool because one of the tomcat rpms already
provides /usr/bin/jasper.

I'll look into where the code hard-codes calls to (/usr/bin/)jasper.
Comment 2 Rex Dieter 2006-01-31 10:18:14 EST
And, we'll try to determine why /usr/bin/jiv wasn't included.
Comment 3 Rex Dieter 2006-01-31 10:35:33 EST
Other than kopete, do you have any other examples of application errors/failures
related to this?
Comment 4 Rex Dieter 2006-01-31 10:39:05 EST
I ask, because it appears kopete simply looks for the jasper binary when using
the yahoo chat protocol:
$ grep -r jasper 
kopete/protocols/yahoo/yahoocontact.cpp:        if (
!KStandardDirs::findExe("jasper") )
kopete/protocols/yahoo/yahoocontact.cpp:                        i18n("Jasper
image conversion program not found.\njasper is required to render the Yahoo
webcam images.\nPlease go to %1").arg( "http://www.ece.uvic.ca/~mdadams/jasper/")
kopete/protocols/yahoo/kyahoo.cpp:              p << "jasper";
kopete/protocols/yahoo/kyahoo.cpp:                      kdDebug(14181) << "
jasper exited with status " << p.exitStatus() << " " << who << endl;

So we're stuck on the jasper end of things.  Looks like kdenetwork might need
patching.
Comment 5 Rex Dieter 2006-01-31 10:43:39 EST
Good news, looks like FC4's tomcat5-jasper pkg now provides:
/usr/bin/jasper5
so, we can go back to /usr/bin/jasper.  Problem averted.
Comment 6 Rex Dieter 2006-01-31 13:43:27 EST
Thanks for the report, fixed in jasper-1.701.0-9
Comment 7 Rex Dieter 2006-01-31 13:44:26 EST
FYI,
* Tue Jan 31 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.701.0-9
- workaround "freeglut-devel should Requires: libGL-devel, libGLU-devel"
  (#179464)

* Tue Jan 31 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.701.0-8
- revert jasper to jaspertool rename (#176773)
- actually use/apply GL patch
Comment 8 tannhaus 2006-01-31 20:51:50 EST
Thank you VERY much.  It's great to see when you discover a bug that you can 
bring it up and people care enough to listen/look into it.  Kudos to you. 

Note You need to log in before you can comment on or make changes to this bug.