Bug 176775 - nice'd jobs should also boost the CPU
nice'd jobs should also boost the CPU
Status: CLOSED DUPLICATE of bug 132383
Product: Fedora
Classification: Fedora
Component: cpuspeed (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-02 03:44 EST by Michal Szymanski
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-02 06:26:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Szymanski 2006-01-02 03:44:38 EST
Description of problem:
I have just noticed that 'cpuspeed' daemon ignores nice'd jobs. Unfortunately
'kernel-utils' package lacks and documentation on 'cpuspeed' so I had to search
the net and found, to my great surprise, on Carl Thompson's (the author) WWW
pages that this is a FEATURE. Well, I would argue that this is a BUG. Nice'd
jobs are not meant to run *slow*, they are meant not to disturb other,
short-lived jobs. Especially in local networks, where machines are used by
several people at the same time, users are encouraged to nice their long-running
jobs in order to make other people using editors, mailers etc, comfortable.
Also, this behaviour is kind of self-contradiction to what 'cpuspeed' help says:
"... it increases the CPU speed when the system is not idle...". Well, with a
nice'd long-running job the system is surely not idle.
I'd vote at least to add a configuration option making the 'cpuspeed' monitoring
"idle" status and not "user" status of the CPU(s) (as 'top' reports).

Version-Release number of selected component (if applicable):
kernel-utils-2.4-9.1.131


How reproducible:
always


Steps to Reproduce:
1. make sure 'cpuspeed' is running and the CPU is supporting frequency changes
2. wait till CPU(s) goes into "low speed" status
3. run a nice'd job: "nice +19 command"
4. check CPU frequency - it will not increase

  
Actual results:
CPU freaquency stays "low"

Expected results:
It should go "high"

Additional info:
Comment 1 Michal Szymanski 2006-01-02 06:26:28 EST
In the meantime I have found this problem resolved in FC Development tree, as
"cpuspeed-1.2.1-1.28" (still no manpage, also no docs on author's page so I
could not find the new "-n" option before I reported in the original post). 

The source RPM builds w/o any problem on FC3, the only problem remaining that
FC3 has 'cpuspeed' integrated into 'kernel-utils' so one needs "--force" option
to install the new 'cpuspeed'. Would be profitable to get new 'cpuspeed'
included into 'kernel-utils' for FC3 users.

regards, Michal.

*** This bug has been marked as a duplicate of 132383 ***

Note You need to log in before you can comment on or make changes to this bug.