Bug 1767826 - Rule details in scan HTML reports generated by Openscap are not accessible to screenreader users
Summary: Rule details in scan HTML reports generated by Openscap are not accessible to...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openscap
Version: 7.8
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Vojtech Polasek
QA Contact: Matus Marhefka
Mirek Jahoda
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-01 13:43 UTC by Vojtech Polasek
Modified: 2020-03-31 20:11 UTC (History)
7 users (show)

Fixed In Version: openscap-1.2.17-6.el7
Doc Type: Bug Fix
Doc Text:
.Accessibility of `OpenSCAP` HTML reports has been improved Previously, an Accessible Rich Internet Applications (ARIA) parameter was incorrectly defined in `OpenSCAP` HTML reports. As a consequence, rule details in the reports were not accessible to users of screenreading software. With this update, the template for report generation has been changed. As a result, users with screen readers can now navigate through rule details and interact with links and buttons.
Clone Of: 1767382
Environment:
Last Closed: 2020-03-31 20:11:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1183 None None None 2020-03-31 20:11:19 UTC

Description Vojtech Polasek 2019-11-01 13:43:24 UTC
+++ This bug was initially created as a clone of Bug #1767382 +++

Description of problem:

I am a screenreader Linux user. When I try to open a rule detail in a HTML scan report generated with Openscap, the window visually appears but due to wrongly configured ARIA argument it is not detected by the screenreader and therefore there is no way for me how to read or interact with it.


Version-Release number of selected component (if applicable):
1..2.17-4.l7

How reproducible:

Always.

Steps to Reproduce:
1. Install openscap-scanner
2. install scap-security-guide
3. Perform a scan, for example
oscap xccdf eval --profile ospp --report result.html /usr/share/xml/scap/ssg/content/ssg-rhel8-ds.xml
4. Run the Orca screenreader and open the HTML report in Firefox browser
5. In the tree of rules navigate to any individual rule and press enter.

Actual results:
The rule details visually appear, but the Orca screenreader is not able to read it.

Expected results:
The details appear and Orca screenreader is able to read it and interact with controls.


Additional info:
The fix has been merged into upstream 
https://github.com/OpenSCAP/openscap/pull/1383

Comment 10 errata-xmlrpc 2020-03-31 20:11:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1183


Note You need to log in before you can comment on or make changes to this bug.