Bug 1767846 - Setting manual approval strategy ignored for subsequent releases
Summary: Setting manual approval strategy ignored for subsequent releases
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.z
Assignee: Vu Dinh
QA Contact: Jian Zhang
URL:
Whiteboard:
: 1768504 (view as bug list)
Depends On: 1758008
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-01 14:07 UTC by Bowen Song
Modified: 2019-11-21 09:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1758008
: 1767848 (view as bug list)
Environment:
Last Closed: 2019-11-21 09:17:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1107 0 'None' closed [Release 4.1] Bug 1767846: Manual approval strategy ignored for subsequent releases 2020-04-08 03:51:15 UTC
Red Hat Product Errata RHBA-2019:3875 0 None None None 2019-11-21 09:18:03 UTC

Comment 1 Evan Cordell 2019-11-04 18:24:46 UTC
*** Bug 1768504 has been marked as a duplicate of this bug. ***

Comment 3 Jian Zhang 2019-11-11 09:16:52 UTC
The latest 4.1.z payload: 4.1.0-0.nightly-2019-11-08-121853 which build 2 days ago.
But this fixed PR just merged 3 hours ago. Change status to MODIFIED since no available payload.

Comment 5 Jian Zhang 2019-11-12 10:17:52 UTC
Cluster version is 4.1.0-0.nightly-2019-11-11-220054
OLM version:
mac:~ jianzhang$ oc exec catalog-operator-7945948df5-qr9gl  --  olm --version
OLM version: 0.9.0
git commit: 1bd1fe142d7ae74fd53829132b66e0455716e035


1, Create the csc object:
mac:~ jianzhang$ oc get ip -n openshift-operators
NAME            CSV                               SOURCE   APPROVAL   APPROVED
install-92klx   etcdoperator.v0.9.2-clusterwide            Manual     false
mac:~ jianzhang$ cat csc-41.yaml 
apiVersion: operators.coreos.com/v1
kind: CatalogSourceConfig
metadata:
  name: jian-operators
  namespace: openshift-marketplace
spec:
  csDisplayName: Community Operators
  csPublisher: Community
  packages: etcd
  targetNamespace: openshift-operators
mac:~ jianzhang$ oc create -f csc-41.yaml 
catalogsourceconfig.operators.coreos.com/jian-operators created

2, Create a subscription for the v0.9.2 etcd-operator with manual approval.
mac:~ jianzhang$ cat sub-41-manual.yaml 
apiVersion: operators.coreos.com/v1alpha1
kind: Subscription
metadata:
  name: etcd-manual
  namespace: openshift-operators
spec:
  channel: clusterwide-alpha
  installPlanApproval: Manual
  name: etcd
  source: jian-operators
  sourceNamespace: openshift-operators
  startingCSV: etcdoperator.v0.9.2-clusterwide

mac:~ jianzhang$ oc get sub -n openshift-operators
NAME          PACKAGE   SOURCE           CHANNEL
etcd-manual   etcd      jian-operators   clusterwide-alpha
mac:~ jianzhang$ oc get ip -n openshift-operators
NAME            CSV                               SOURCE   APPROVAL   APPROVED
install-92klx   etcdoperator.v0.9.2-clusterwide            Manual     false

mac:~ jianzhang$ oc get csv -n openshift-operators
No resources found in openshift-operators namespace.

3, Approval this etcdoperator.v0.9.2-clusterwide InstallPlan. This etcdoperator.v0.9.2-clusterwide was not approval automatically. LGTM.
mac:~ jianzhang$ oc edit ip install-92klx -n openshift-operators
installplan.operators.coreos.com/install-92klx edited
mac:~ jianzhang$ oc get ip -n openshift-operators
NAME            CSV                               SOURCE   APPROVAL   APPROVED
install-2svbv   etcdoperator.v0.9.4-clusterwide            Manual     false
install-92klx   etcdoperator.v0.9.2-clusterwide            Manual     true
mac:~ jianzhang$ oc get csv -n openshift-operators
NAME                              DISPLAY   VERSION             REPLACES              PHASE
etcdoperator.v0.9.2-clusterwide   etcd      0.9.2-clusterwide   etcdoperator.v0.9.0   Succeeded

4, Approval this etcdoperator.v0.9.4-clusterwide InstallPlan. This etcdoperator.v0.9.4 etcd operator can be installed successfully. LGTM. Verify it.
mac:~ jianzhang$ oc get csv -n openshift-operators
NAME                              DISPLAY   VERSION             REPLACES                          PHASE
etcdoperator.v0.9.4-clusterwide   etcd      0.9.4-clusterwide   etcdoperator.v0.9.2-clusterwide   Succeeded
mac:~ jianzhang$ oc get ip -n openshift-operators
NAME            CSV                               SOURCE   APPROVAL   APPROVED
install-2svbv   etcdoperator.v0.9.4-clusterwide            Manual     true
install-92klx   etcdoperator.v0.9.2-clusterwide            Manual     true
mac:~ jianzhang$ oc get csv -n openshift-operators
NAME                              DISPLAY   VERSION             REPLACES                          PHASE
etcdoperator.v0.9.2-clusterwide   etcd      0.9.2-clusterwide   etcdoperator.v0.9.0               Replacing
etcdoperator.v0.9.4-clusterwide   etcd      0.9.4-clusterwide   etcdoperator.v0.9.2-clusterwide   Installing

Comment 6 Jian Zhang 2019-11-12 10:19:51 UTC
mac:~ jianzhang$ oc get csv -n openshift-operators
NAME                              DISPLAY   VERSION             REPLACES                          PHASE
etcdoperator.v0.9.4-clusterwide   etcd      0.9.4-clusterwide   etcdoperator.v0.9.2-clusterwide   Succeeded

Comment 8 errata-xmlrpc 2019-11-21 09:17:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3875


Note You need to log in before you can comment on or make changes to this bug.