This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 176785 - Scriptlets do not make sense
Scriptlets do not make sense
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-02 13:35 EST by Enrico Scholz
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-03 00:03:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2006-01-02 13:35:45 EST
of problem:

the %post/%preun scripts contain code like

| [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg ...

This statement makes no sense and causes confusion when /sbin/new-kernel-pkg
does not exists. In this case, the entire expression and the scriptlet will fail
silently without telling the reason. Failing scriptlets are a problem because
they can prevent proper package installation/deinstallation.


I suggest to write either

| [ ! -x /sbin/new-kernel-pkg ] || /sbin/new-kernel-pkg

or omit the [ ... ] completely (which would tell the reason why the scriptlet
fails).


Version-Release number of selected component (if applicable):

kernel-2.6.14-1.1696_FC5
Comment 1 Dave Jones 2006-01-03 00:03:14 EST
removed in cvs.

Note You need to log in before you can comment on or make changes to this bug.