Bug 1767853 - Kubevirt pages for management console do not load on Edge browser
Summary: Kubevirt pages for management console do not load on Edge browser
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Marek Libra
QA Contact: Nelly Credi
URL:
Whiteboard:
: 1767856 (view as bug list)
Depends On:
Blocks: 1767865
TreeView+ depends on / blocked
 
Reported: 2019-11-01 14:24 UTC by Steve Goodwin
Modified: 2020-01-23 11:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: VirtualMachine page does not load in the MS Edge browser Consequence: The user can not access virtualization when using the Edge browser Fix: JavaScript incompatibility has been fixed. Result: The page loads fine.
Clone Of:
: 1767865 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:10:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
MS Edge console error (168.39 KB, image/png)
2019-11-04 18:47 UTC, Robb Hamilton
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3230 'None' 'closed' 'Bug 1767853: Bump kubevirt-web-ui-components v0.1.50' 2019-11-27 09:23:32 UTC
Red Hat Knowledge Base (Solution) 4550701 None None None 2019-11-04 15:38:44 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:10:40 UTC

Description Steve Goodwin 2019-11-01 14:24:07 UTC
Description of problem:
Web console will not display on MS Edge

Comment 1 Steve Goodwin 2019-11-01 14:32:00 UTC
*** Bug 1767856 has been marked as a duplicate of this bug. ***

Comment 2 Robb Hamilton 2019-11-04 18:47:14 UTC
Created attachment 1632714 [details]
MS Edge console error

Comment 3 Samuel Padgett 2019-11-04 21:19:55 UTC
This is a problem with the spread operator in kubevirt-web-ui-components. Fix in https://github.com/kubevirt/web-ui-components/pull/572

Comment 4 Samuel Padgett 2019-11-04 22:15:46 UTC
Browser support: https://access.redhat.com/articles/4128421

Comment 6 Guohua Ouyang 2019-11-12 06:43:22 UTC
verified on macOS Edge, the pages are loading well.
version: 4.3.0-0.nightly-2019-11-02-092336

Comment 8 errata-xmlrpc 2020-01-23 11:10:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.