Bug 176786 - cups fails to install lexmark z600 printer driver
cups fails to install lexmark z600 printer driver
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2006-01-02 13:39 EST by Jose_Saucedo
Modified: 2008-03-10 19:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-10 19:53:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/var/log/cups/error_log for lexmark z600 driver (7.80 KB, text/plain)
2006-01-04 14:01 EST, Jose_Saucedo
no flags Details
debug level 2 error log for cups lexmark z600 driver (79.22 KB, text/plain)
2006-01-09 11:53 EST, Jose_Saucedo
no flags Details

  None (edit)
Description Jose_Saucedo 2006-01-02 13:39:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Description of problem:
The lexmark z600 printer driver is usefull to control the x1100 series printers (I use a x1185, all in one, usb plug), which works fine on fc2 and fc3. Recently, I upgraded to fc4, and it stopped working. The CUPS gui succeeds on listing the driver as available, and "successfuly" installs the printer; nevertheless, at the moment of sending the test page, nothing comes out, but CUPS says it did send the page. If you check the printer queue, it says the print job was sent less than a minute ago, never passing through an "active job" phase; after a while, it will a ppear a window from eggcups, with the message "the jobprint xxx was aborted. Maybe you would like to know why", an "accept" button, and nothing else. Clicking on "clear jobs list" at the printer descriptions in the cups gui takes you to a "client-error-not-possible" message.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install the z600 rpm packages
2.Use the cups gui to install the printer
3.send a test page, and the printer will fail to work
4.You get an error message from eggcups

Actual Results:  CUPS fails to work

Expected Results:  CUPS used to manage greatly the printer on fc2 and fc3, but fails at fc4

Additional info:

When getting the whole installation pack, apart from the rpms, there is an installation script (which, as advised by other people in forums, is expected NOT to work, which anyways i tried to use to see if i could get any output from it) and asks for components form tcl libraries version 3.4, while fc4 has 3.5. It is advised to make a symbolic link; doing this does not work. Forcing the installation of tcl 3.4 will not work, either.

On fc3 and fc2, at the phase of selecting the driver, the only available driver on lexmark was the z600, while on fc4, all the drivers are listed together with z600
Comment 1 Tim Waugh 2006-01-03 04:11:25 EST
Please attach /var/log/cups/error_log.  Thanks.
Comment 2 Jose_Saucedo 2006-01-04 14:01:06 EST
Created attachment 122774 [details]
/var/log/cups/error_log for lexmark z600 driver

log for jan 3 contains the steps described in the bug, previous dates also
contain attempts to make the printer to work with other lexmark drivers, with
no result. Thanks for your quick answer
Comment 3 Jose_Saucedo 2006-01-04 15:35:47 EST
Hi, the log is online.

(In reply to comment #1)
> Please attach /var/log/cups/error_log.  Thanks.

Comment 4 Tim Waugh 2006-01-05 07:21:57 EST
Now please edit the file /etc/cups/cupsd.conf and change the 'LogLevel' line to

LogLevel debug2

Then stop cups:

  /sbin/service cups stop

Clear out the error_log file:


And start cups again:

  /sbin/service cups start

Try printing again, and attach the new /var/log/cups/error_log file.  Thanks.
Comment 5 Jose_Saucedo 2006-01-09 11:53:49 EST
Created attachment 122955 [details]
debug level 2 error log for cups lexmark z600 driver

Steps done: 
stopped cups
cleared error_log
restarted cups
declared printer with z600 driver
sent testpage
listed jobs
asked to cancel job after no response from printer
got client-error-not-possible message
stopped cups

Setting debug level 2 made the eggcups message to never come out.
Comment 6 Jose_Saucedo 2006-06-26 17:07:02 EDT
The bug still persists on FC5, even the first time FC5 is installed, cups does 
not even show lexmark as maker when selecting the printer model.
Comment 7 Tim Waugh 2006-12-15 08:54:24 EST
Changing component and version.  Very sorry for the delay!

Are you still able to reproduce this bug?
Comment 8 petrosyan 2008-03-10 19:53:09 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.

Note You need to log in before you can comment on or make changes to this bug.