Bug 1767946 - Networking Granular Checks: Services should function for pod-Service: udp
Summary: Networking Granular Checks: Services should function for pod-Service: udp
Keywords:
Status: CLOSED DUPLICATE of bug 1763936
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Ricardo Carrillo Cruz
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-01 17:19 UTC by Ben Parees
Modified: 2019-11-23 05:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-23 05:45:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ben Parees 2019-11-01 17:19:42 UTC
Description of problem:
Test failure in CI:

[sig-network] Networking Granular Checks: Services should function for pod-Service: udp [Suite:openshift/conformance/parallel] [Suite:k8s]

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-aws-upi-4.3/240

possibly related to similar test failures:
https://bugzilla.redhat.com/show_bug.cgi?id=1763936
https://bugzilla.redhat.com/show_bug.cgi?id=1763940


fail [k8s.io/kubernetes/test/e2e/framework/networking_utils.go:250]: Nov  1 15:20:50.954: Failed to find expected endpoints:
Tries 66
Command curl -g -q -s 'http://10.128.1.14:8080/dial?request=hostName&protocol=udp&host=10.0.57.9&port=30548&tries=1'
retrieved map[netserver-1:{} netserver-2:{} netserver-3:{} netserver-5:{}]
expected map[netserver-0:{} netserver-1:{} netserver-2:{} netserver-3:{} netserver-4:{} netserver-5:{}]

Comment 2 Ricardo Carrillo Cruz 2019-11-20 08:51:39 UTC
I am unable to run this on a cluster:

<snip>

Nov 20 09:45:27.722: INFO: >>> kubeConfig: /home/ricky/openshift-installer/rcarrillocruz-granular/auth/kubeconfig
Nov 20 09:45:27.725: INFO: >>> kubeConfig: /home/ricky/openshift-installer/rcarrillocruz-granular/auth/kubeconfig
started: (0/1/1) "[sig-network] Networking Granular Checks: Services should function for pod-Service: udp [Suite:openshift/conformance/parallel] [Suite:k8s]"

Nov 20 09:45:54.763: INFO: >>> kubeConfig: /home/ricky/openshift-installer/rcarrillocruz-granular/auth/kubeconfig
Nov 20 09:45:54.765: INFO: >>> kubeConfig: /home/ricky/openshift-installer/rcarrillocruz-granular/auth/kubeconfig
Nov 20 09:46:15.465: INFO: >>> kubeConfig: /home/ricky/openshift-installer/rcarrillocruz-granular/auth/kubeconfig
Nov 20 09:46:15.466: INFO: Waiting up to 30m0s for all (but 100) nodes to be schedulable
Nov 20 09:46:16.454: INFO: Waiting up to 10m0s for all pods (need at least 0) in namespace 'kube-system' to be running and ready
Nov 20 09:46:18.711: INFO: 0 / 0 pods in namespace 'kube-system' are running and ready (2 seconds elapsed)
Nov 20 09:46:18.711: INFO: expected 0 pod replicas in namespace 'kube-system', 0 are Running and Ready.
Nov 20 09:46:18.711: INFO: Waiting up to 5m0s for all daemonsets in namespace 'kube-system' to start
Nov 20 09:46:18.872: INFO: e2e test version: v1.16.2
Nov 20 09:46:19.027: INFO: kube-apiserver version: v1.16.2
Nov 20 09:46:19.027: INFO: >>> kubeConfig: /home/ricky/openshift-installer/rcarrillocruz-granular/auth/kubeconfig
Nov 20 09:46:19.188: INFO: Cluster IP family: ipv4
[BeforeEach] [Top Level]
  /home/ricky/go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/test/extended/util/test.go:60
[BeforeEach] [sig-network] Networking
  /home/ricky/go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/test/e2e/framework/framework.go:151
STEP: Creating a kubernetes client
Nov 20 09:46:19.189: INFO: >>> kubeConfig: /home/ricky/openshift-installer/rcarrillocruz-granular/auth/kubeconfig
STEP: Building a namespace api object, basename nettest
Nov 20 09:46:19.831: INFO: About to run a Kube e2e test, ensuring namespace is privileged
Nov 20 09:46:27.187: INFO: No PodSecurityPolicies found; assuming PodSecurityPolicy is disabled.
STEP: Waiting for a default service account to be provisioned in namespace
[BeforeEach] [sig-network] Networking
  /home/ricky/go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/test/e2e/network/networking.go:35
STEP: Executing a successful http request from the external internet
[It] should function for pod-Service: udp [Suite:openshift/conformance/parallel] [Suite:k8s]
  /home/ricky/go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/test/e2e/network/networking.go:114
STEP: Performing setup for networking test in namespace e2e-nettest-5713
STEP: creating a selector
STEP: Creating the service pods in kubernetes
Nov 20 09:46:27.921: INFO: Waiting up to 10m0s for all (but 100) nodes to be schedulable
STEP: Creating test pods
STEP: Getting node addresses
Nov 20 09:47:11.181: INFO: Waiting up to 10m0s for all (but 100) nodes to be schedulable
Nov 20 09:47:15.480: INFO: Requires at least 2 nodes (not 0)
[AfterEach] [sig-network] Networking
  /home/ricky/go/src/github.com/openshift/origin/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/test/e2e/framework/framework.go:152
Nov 20 09:47:15.481: INFO: Waiting up to 3m0s for all (but 100) nodes to be ready
STEP: Destroying namespace "e2e-nettest-5713" for this suite.
Nov 20 09:47:17.025: INFO: Running AfterSuite actions on all nodes
Nov 20 09:47:17.025: INFO: Running AfterSuite actions on node 1
skip [k8s.io/kubernetes/test/e2e/framework/networking_utils.go:598]: Requires at least 2 nodes (not 0)

skipped: (1m24s) 2019-11-20T08:47:17 "[sig-network] Networking Granular Checks: Services should function for pod-Service: udp [Suite:openshift/conformance/parallel] [Suite:k8s]"

0 pass, 1 skip (1m24s)
[ricky@ricky-laptop origin]$ oc get nodes
NAME                                         STATUS   ROLES    AGE   VERSION
ip-10-0-133-53.us-east-2.compute.internal    Ready    master   17h   v1.16.2
ip-10-0-139-139.us-east-2.compute.internal   Ready    worker   17h   v1.16.2
ip-10-0-147-216.us-east-2.compute.internal   Ready    master   17h   v1.16.2
ip-10-0-150-15.us-east-2.compute.internal    Ready    worker   17h   v1.16.2
ip-10-0-169-192.us-east-2.compute.internal   Ready    worker   17h   v1.16.2
ip-10-0-175-247.us-east-2.compute.internal   Ready    master   17h   v1.16.2

</snip>

Will keep digging.

Comment 3 W. Trevor King 2019-11-23 05:45:46 UTC
Closing this a dup of the earlier bug 1763936, which has all three missing skips.

*** This bug has been marked as a duplicate of bug 1763936 ***


Note You need to log in before you can comment on or make changes to this bug.