Bug 176795 - add scheduled short and long tests to default install
add scheduled short and long tests to default install
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: smartmontools (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-02 15:42 EST by Dan Hollis
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-02 16:04:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Hollis 2006-01-02 15:42:12 EST
Description of problem:
it would be nice if weekly/bi-monthly short and long offline tests were made
part of the default install. eg instead of:

/dev/hda -H -m root@localdomain.localhost

it could be something like
/dev/hda -H -s (S/../.././01|L/../(01|15)/./03) -m root@localdomain.localhost

(daily short offline, and bi-weekly long offline tests)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tomas Mraz 2006-01-02 16:04:14 EST
There can be potential conflicts (or at least slowdowns) caused by the offline
tests. As anyone can reconfigure smartd.conf as he wishes I don't think it's
necessary or even safe to enable them for everyone by default.
Comment 2 Dan Hollis 2006-01-02 16:15:44 EST
can't be any worse slowdown than fedora's automatically scheduling
makewhatis.cron by default. as an extension of this reasoning, makewhatis.cron
should be disabled by default, since that has definite severe performance impact.
Comment 3 Tomas Mraz 2006-01-02 17:07:22 EST
Well I can even agree with you that makewhatis.cron shouldn't be run
automatically by default, but this is a completely different bug.

Also I'm afraid that on some buggy disks/IDE controllers it could create even
bigger problems than slowdowns.
Comment 4 Dan Hollis 2006-01-02 17:21:57 EST
then perhaps smartd shouldnt be installed by default at all then.

it is installed by default now, and even started by default with all available
drives monitored by default, which could be bad on buggy disks/IDE controllers
as you stated.
Comment 5 Dan Hollis 2006-01-10 00:37:07 EST
do you agree smartd should not be installed by default? it is too dangerous and
risky for buggy disks/IDE controllers.

Note You need to log in before you can comment on or make changes to this bug.