Bug 176800 - Kernel panics when anaconda is search for mouse
Kernel panics when anaconda is search for mouse
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-02 18:50 EST by Theo Van Dinter
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 00:19:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial console output showing kernel boot and panic (9.48 KB, text/plain)
2006-01-02 18:51 EST, Theo Van Dinter
no flags Details

  None (edit)
Description Theo Van Dinter 2006-01-02 18:50:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/416.12 (KHTML, like Gecko) Safari/416.13

Description of problem:
Per bug 176624, I was attempting to upgrade my FC3 x86_64 install to FC4.  However, after booting off 
the CD (either "linux" or "linux text"), selecting "skip" for CD testing, anaconda would run with:

Running anaconda...
Probing video...
Probing monitor...
<kernel panic -- I'll attach shortly>

the kernel panic would happen no matter what options I tried, always refering to the serial port.  After 
swearing a lot, I was about to give up looked through BIOS and found that there's a com2 which I had 
disabled because there is no physical com2 serial port on the machine.  For kicks, I enabled it, and then 
anaconda had no problems and things progressed.  Looking at the serial console output, it looks like 
when the serial port is disabled, the kernel is still able to see it with an IRQ of -1, and I'm assuming that 
the kernel dies when trying to access it since it doesn't actually exist.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. insert FC4 disc
2. boot off the CD
  

Additional info:
Comment 1 Theo Van Dinter 2006-01-02 18:51:05 EST
Created attachment 122699 [details]
serial console output showing kernel boot and panic

Please let me know if you need any more information.  Thanks.
Comment 2 Theo Van Dinter 2006-01-02 18:52:22 EST
moving to kernel component -- I put anaconda on originally since that's where the panic was happening, 
but since it's a panic it's the kernel ... sorry. ;)
Comment 3 Dave Jones 2006-01-05 20:32:40 EST
ok, it sounds like you managed to get it installed at least.  After installing
the latest update kernel, does it crash at any stage in the same way ?
Comment 4 Theo Van Dinter 2006-01-13 23:44:09 EST
I haven't seen a crash since changing the BIOS option.  I didn't change it back after the upgrade was 
completed, so I can't say whether or not it was related to the kernel used in the installer or if it's still in the 
later kernels.
Comment 5 Dave Jones 2006-01-17 00:19:14 EST
ok, then I'll close this out.

Note You need to log in before you can comment on or make changes to this bug.