Bug 1768050 - Adjust to ansible packaging changes
Summary: Adjust to ansible packaging changes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ansible-lint
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-02 00:50 UTC by Kevin Fenzi
Modified: 2019-11-06 13:45 UTC (History)
2 users (show)

Fixed In Version: ansible-lint-4.1.1a0-4.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-06 13:45:04 UTC
Type: Bug


Attachments (Terms of Use)

Description Kevin Fenzi 2019-11-02 00:50:05 UTC
Greetings. 

Not long ago I cleaned up the ansible spec for fedora* and epel8. Since we no longer had any python2 there, I moved to a python3 setup with everything in the ansible package. 

Unfortunately, I didn't notice that this broke ansible-lint. 

Can you please adjust requires? There's not a python3-ansible package anymore, just ansible. If you prefer I can do this also. 

I have a ansible update with -1 karma due to this, so it would be nice to build new ansible-lint and then let me attach it to the same update. 

Thanks.

Comment 1 Parag Nemade 2019-11-02 07:49:19 UTC
I fixed this but with updated new upstream source which removed setup.py from code. I am figuring out how to build python package without setup.py file.
Meanwhile, I can revert the change to only have "Requires: ansible"

Comment 2 Parag Nemade 2019-11-02 14:01:07 UTC
I have done the required updates for F29+.
Please take care of bodhi updates.
I see I missed to include this bug number in spec changelog.
Thank you for this bug Kevin.

Comment 3 Fedora Update System 2019-11-02 18:57:41 UTC
FEDORA-2019-355f9240c5 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-355f9240c5

Comment 4 Fedora Update System 2019-11-02 18:57:44 UTC
FEDORA-2019-355f9240c5 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-355f9240c5

Comment 5 Fedora Update System 2019-11-02 18:58:15 UTC
FEDORA-2019-a9195834a9 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a9195834a9

Comment 6 Fedora Update System 2019-11-02 18:58:18 UTC
FEDORA-2019-a9195834a9 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a9195834a9

Comment 7 Fedora Update System 2019-11-04 02:09:24 UTC
ansible-2.8.6-1.fc30, ansible-lint-4.1.1a0-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a9195834a9

Comment 8 Fedora Update System 2019-11-04 02:18:14 UTC
ansible-2.8.6-1.fc31, ansible-lint-4.1.1a0-4.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-355f9240c5

Comment 9 Fedora Update System 2019-11-06 13:45:04 UTC
ansible-2.8.6-1.fc31, ansible-lint-4.1.1a0-4.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.