Bug 1768298 - Gather events for namespaces defined as related objects in degraded operators
Summary: Gather events for namespaces defined as related objects in degraded operators
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Insights Operator
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Ivan Necas
QA Contact: Dmitry Misharov
Radek Vokál
URL:
Whiteboard:
Depends On:
Blocks: 1767719
TreeView+ depends on / blocked
 
Reported: 2019-11-04 01:41 UTC by Derek Carr
Modified: 2020-01-23 11:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1767719
Environment:
Last Closed: 2020-01-23 11:10:26 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:10:40 UTC

Description Derek Carr 2019-11-04 01:41:51 UTC
+++ This bug was initially created as a clone of Bug #1767719 +++

Description of problem:

Events provide timelines when failures happen and help debugging problems.
A concrete example is CNI "network not ready" that will cause containers to be stucked in pending when the container network is down (SDN). In case of kube-apiserver-operator it can cause the installer pods being stucked and the operator will be effectively blocked.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Derek Carr 2019-11-04 01:44:14 UTC
https://github.com/openshift/insights-operator/pull/36

4.3 master branch fix merged.

updating to modified pending verification for including in 4.2.z

Comment 3 Dmitry Misharov 2019-11-18 13:20:27 UTC
Verified on 4.3.0-0.ci-2019-11-18-065034. In order to verify we need to make some operators be degraded. Here are steps for authentication operator:
1. oc edit clusterversion
2. Add override for openshift-ingress-operator:
  overrides:
  - group: apps/v1
    kind: Deployment
    name: ingress-operator
    namespace: openshift-ingress-operator
    unmanaged: true
3. Scale the ingress operator to 0
4. oc delete pods --all -n openshift-ingress (that will remove router pods)
5. oc delete pods --all -n openshift-authentication-operator (that will rekick auth operator so you don't have to wait)
6. oc delete pods --all -n openshift-insights (that will kick insights operator)
7. Check insights-archive. There should events folder with recorded events.

Comment 5 errata-xmlrpc 2020-01-23 11:10:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.