Bug 176832 - unicode_start started for each and every shell script
unicode_start started for each and every shell script
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-03 10:13 EST by Bastien Nocera
Modified: 2014-03-16 22:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 16:52:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bash-no-unicode-start-for-child-bash.patch (465 bytes, patch)
2006-01-03 10:13 EST, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2006-01-03 10:13:29 EST
initscripts-7.93.20.EL-1

When a bash shell script starts another shell script, you can end up with a load
of unicode_start processes.

- bash program starts
- calls unicode_start, which is a bash script
- calls unicode_start, which is a bash script
etc.

I could not reproduce the problem locally, but the patch attached fixes it for
the person seeing the problem.
Comment 1 Bastien Nocera 2006-01-03 10:13:29 EST
Created attachment 122714 [details]
bash-no-unicode-start-for-child-bash.patch
Comment 2 Bill Nottingham 2006-01-06 16:52:31 EST
It happens because someone has BASH_ENV set in their .bash_profile - don't do
that. (See #172059).

This problem is resolved in the next release of Red Hat Enterprise Linux. Red
Hat does not currently plan to provide a resolution for this in a Red Hat
Enterprise Linux update for currently deployed systems.

With the goal of minimizing risk of change for deployed systems, and in response
to customer and partner requirements, Red Hat takes a conservative approach when
evaluating changes for inclusion in maintenance updates for currently deployed
products. The primary objectives of update releases are to enable new hardware
platform support and to resolve critical defects. 

Comment 3 Bill Nottingham 2006-02-07 14:05:26 EST
Note that this fix breaks unicode initialization for vt2-vt6. It has been reverted.
Comment 4 Bill Nottingham 2006-03-17 12:28:53 EST
Adding devel NAK; as the fix was incorrect and caused regressions.

Note You need to log in before you can comment on or make changes to this bug.