Bug 1768337 - [RHVH4.3.7] The NICs are turned off during installation, but found that all NICs are open after installation [NEEDINFO]
Summary: [RHVH4.3.7] The NICs are turned off during installation, but found that all N...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 4.3.7
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ovirt-4.3.7
: 4.3.7
Assignee: Yuval Turgeman
QA Contact: peyu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-04 06:30 UTC by peyu
Modified: 2019-12-12 10:37 UTC (History)
16 users (show)

Fixed In Version: vdsm-4.30.38
Doc Type: Bug Fix
Doc Text:
Previously, NICs on a Red Hat Virtualization Host you had configured to remain off were turned back on after rebooting. This happened because a bug expanded %{_libdir} to /usr/lib64 instead of /usr/lib and failed to disable clevis. The current release fixes this bug so that these NICs remain off.
Clone Of:
Environment:
Last Closed: 2019-12-12 10:36:52 UTC
oVirt Team: Node
Target Upstream Version:
rdlugyhe: needinfo? (yturgema)


Attachments (Terms of Use)
/var/log (763.13 KB, application/gzip)
2019-11-04 07:52 UTC, peyu
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:4230 0 None None None 2019-12-12 10:37:13 UTC
oVirt gerrit 104414 0 'None' ABANDONED network: Avoid dracut overwriting ifcfg files 2021-01-31 18:27:05 UTC
oVirt gerrit 104420 0 'None' MERGED network: disable clevis dracut module 2021-01-31 18:27:05 UTC
oVirt gerrit 104457 0 'None' MERGED network: disable clevis dracut module 2021-01-31 18:27:05 UTC

Description peyu 2019-11-04 06:30:49 UTC
Description of problem:
The NICs are turned off during installation, but after installation is complete,log in to RHVH and found that all NICs are turned on.

Version-Release number of selected component (if applicable):
Test version:
RHVH-4.3-20191103.0-RHVH-x86_64-dvd1.iso

How reproducible:
100%

Steps to Reproduce:
1. Install RHVH-4.3-20191103.0-RHVH-x86_64-dvd1.iso via Anaconda GUI
2. Enter "NETWORK & HOST NAME" page, set Ethernet(eno1) on and check the checkbox "Automatically connect to this network when it is available", keep other NICs  off.
3. Finish the installation and reboot
4. Log in to RHVH
5. Check the network via shell 
   # ip a s
6. Log in to cockpit and turn off NICs via cockpit
7. Reboot and enter RHVH shell
8. Check the network again via shell 
   # ip a s

Actual results:
1. In step 5, found all NICs are turned on.
2. In step 8, the NICs that were turned off via cockpit were all opened again.

Expected results:
1. In step 5, only Ethernet(eno1) is up, other NICs should be turned off.
2. In step 8, the NICs that are turned off via cockpit should be persistent after rebooting.

Additional info:

Comment 5 peyu 2019-11-04 07:52:14 UTC
Created attachment 1632428 [details]
/var/log

Comment 14 cshao 2019-11-14 13:09:50 UTC
Confirmed by qin, the bug still can reproduce with the latest 4.3.7 (redhat-virtualization-host-4.3.7-20191113.0.el7_7), so move to assigned.

Comment 15 Yuval Turgeman 2019-11-14 13:38:48 UTC
My bad, %{_libdir} is expanded to /usr/lib64 instead of /usr/lib so clevis wasn't disabled

Comment 16 Michael Burman 2019-11-14 13:42:17 UTC
Network team also managed to reproduce it on redhat-virtualization-host-4.3.7-20191113.0.el7_7

Comment 17 Sandro Bonazzola 2019-11-18 08:03:21 UTC
Please retest with redhat-virtualization-host-4.3.7-20191115.0.el7_7

Comment 18 peyu 2019-11-19 06:53:21 UTC
This bug has been resolved in redhat-virtualization-host-4.3.7-20191115.0.el7_7

Steps to test:
1. Install redhat-virtualization-host-4.3.7-20191115.0.el7_7 via Anaconda GUI
2. Enter "NETWORK & HOST NAME" page, set Ethernet(eno1) on and check the check-box "Automatically connect to this network when it is available", keep other NICs off.
3. Finish the installation and reboot
4. Log in to RHVH
5. Check the network via shell 
   # ip a s
6. Log in to cockpit and turn on another NIC
7. Reboot and check the network status via cockpit and shell
8. Log in to cockpit and turn off one NIC 
9. Reboot and check the network status again via cockpit and shell


Test result:
The networking works correctly, the NICs that are turned on/off via cockpit can be persistent after rebooting.

So I will move bug status to VERIFIED.

Comment 21 errata-xmlrpc 2019-12-12 10:36:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4230


Note You need to log in before you can comment on or make changes to this bug.