Bug 1768350 - External link in deprecation notes of pipeline build strategy does not exist
Summary: External link in deprecation notes of pipeline build strategy does not exist
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.3.0
Assignee: Steve Goodwin
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-04 07:14 UTC by Yadan Pei
Modified: 2020-04-08 18:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1822128 (view as bug list)
Environment:
Version: 4.3.0-0.nightly-2019-11-02-092336 Cluster ID: bd109f32-5ece-482e-9d5a-d9134371c898
Last Closed: 2020-01-23 11:10:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3218 None closed Bug 1768350: Fix link to redirect 2020-06-28 06:16:20 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:10:40 UTC

Description Yadan Pei 2019-11-04 07:14:48 UTC
Description of problem:
visiting the link in deprecation note for pipeline build strategy gives 404 error

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-11-02-092336

How reproducible:
Always

Steps to Reproduce:
1. Create Jenkins server and Pipeline BC
$ oc new-app https://raw.githubusercontent.com/openshift/origin/master/examples/jenkins/jenkins-ephemeral-template.json
$ oc new-app -f https://raw.githubusercontent.com/openshift/origin/master/examples/jenkins/pipeline/samplepipeline.yaml

2. Admin user login console and view Build Configs via Builds -> Build Configs -> sample-pipeline
3. Check message on BC details

Actual results:
3. There is a deprecation note for Pipeline build strategy:
Pipeline build strategy deprecation
With the release of OpenShift Pipelines based on Tekton, the pipelines build strategy has been deprecated. Users should either use Jenkins files directly on Jenkins or use cloud-native CI/CD with Openshift Pipelines.Try the OpenShift Pipelines tutorial
In the message, there are two external links, 'OpenShift Pipelines based on Tekton' and 'Try the OpenShift Pipelines tutorial', visiting the former link https://openshift.github.io/pipelines-docs/docs/docs/index.html gives 404 Page Not Found error.

Expected results:
3. The link should be correct and existing 

Additional info:

Comment 1 Steve Goodwin 2019-11-04 15:48:21 UTC
PR fix
https://github.com/openshift/console/pull/3218

Comment 4 Yadan Pei 2019-11-06 08:47:34 UTC
Changes are not in 4.3.0-0.nightly-2019-11-05-164935, will check on newer builds

Comment 5 Yadan Pei 2019-11-07 06:39:39 UTC
With the release of OpenShift Pipelines based on Tekton, the pipelines build strategy has been deprecated. Users should either use Jenkins files directly on Jenkins or use cloud-native CI/CD with Openshift Pipelines.Try the OpenShift Pipelines tutorial

Now `OpenShift Pipelines based on Tekton` links to https://openshift.github.io/pipelines-docs/docs/docs/0.7/index.html 

Verified on 4.3.0-0.nightly-2019-11-06-215135

Comment 7 errata-xmlrpc 2020-01-23 11:10:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.