Bug 1768353 - [RHVH4.3.7] After rebooting, the NICs Configuration with "Shared" mode or "Link local" mode cannot be persisted [NEEDINFO]
Summary: [RHVH4.3.7] After rebooting, the NICs Configuration with "Shared" mode or "Li...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 4.3.7
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ovirt-4.3.7
: 4.3.7
Assignee: Yuval Turgeman
QA Contact: peyu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-04 07:35 UTC by peyu
Modified: 2019-12-12 10:37 UTC (History)
16 users (show)

Fixed In Version: vdsm-4.30.38
Doc Type: Bug Fix
Doc Text:
Previously, NICs on a Red Hat Virtualization Host you had configured to use "Shared" or "Link-local" mode did not apply the configuration after reboot. The current release fixes this issue and uses the selected mode after rebooting.
Clone Of:
Environment:
Last Closed: 2019-12-12 10:36:52 UTC
oVirt Team: Node
Target Upstream Version:
rdlugyhe: needinfo? (yturgema)


Attachments (Terms of Use)
/var/log (763.13 KB, application/gzip)
2019-11-04 07:52 UTC, peyu
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:4230 0 None None None 2019-12-12 10:37:13 UTC
oVirt gerrit 104420 0 'None' MERGED network: disable clevis dracut module 2021-01-31 18:27:06 UTC
oVirt gerrit 104457 0 'None' MERGED network: disable clevis dracut module 2021-01-31 18:27:06 UTC

Description peyu 2019-11-04 07:35:52 UTC
Description of problem:
Configure one NIC with shared mode or Link local mode via cockpit, but the configuration can not be saved after rebooting.

Version-Release number of selected component (if applicable):
Test version:
RHVH-4.3-20191103.0-RHVH-x86_64-dvd1.iso

How reproducible:
100%

Steps to Reproduce:
1. Install RHVH-4.3-20191103.0-RHVH-x86_64-dvd1.iso
2. Reboot RHVH and login cockpit, enter to "Networking" page
3. Select one NIC and enter setting page
4. Setup IPv4 as "Shared" mode or "Link local" mode, click "Apply"
5. Reboot and check ip address via cockpit again

Actual results:
1. In step 5, after rebooting, the Mode("Shared" or "Link local") configured in setp 4 cannot be persisted.

Expected results:
1. The Mode("Shared" or "Link local") configured in setp 4 should be persisted.

Additional info:

Comment 5 peyu 2019-11-04 07:52:46 UTC
Created attachment 1632429 [details]
/var/log

Comment 18 peyu 2019-11-15 02:13:18 UTC
This bug can still be reproduced in the latest 4.3.7 (redhat-virtualization-host-4.3.7-20191113.0.el7_7).


Test steps:
1. Install RHVH-4.3-20191113.1-RHVH-x86_64-dvd1.iso
2. Reboot RHVH and login cockpit, enter to "Networking" page
3. Select one NIC and enter setting page
4. Setup IPv4 as "Shared" mode or "Link local" mode, click "Apply"
5. Reboot and check ip address via cockpit again

Actual results:
1. In step 5, after rebooting, the Mode("Shared" or "Link local") configured in setp 4 cannot be persisted.

Expected results:
1. The Mode("Shared" or "Link local") configured in setp 4 should be persisted.


So move bug status to assigned.

Comment 19 Sandro Bonazzola 2019-11-18 08:03:37 UTC
Please retest with redhat-virtualization-host-4.3.7-20191115.0.el7_7

Comment 20 peyu 2019-11-19 07:04:02 UTC
This bug has been resolved in redhat-virtualization-host-4.3.7-20191115.0.el7_7.

Test steps:
1. Install redhat-virtualization-host-4.3.7-20191115.0.el7_7
2. Reboot RHVH and log in to cockpit, then enter "Networking" page
3. Select one NIC and enter setting page
4. Setup IPv4 as "Shared" mode or "Link local" mode, click "Apply"
5. Reboot and check the ip address via cockpit again

Test result:
1. The Mode("Shared" or "Link local") configured in setp 4 can be persisted.


So move bug status to VERIFIED.

Comment 23 errata-xmlrpc 2019-12-12 10:36:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4230


Note You need to log in before you can comment on or make changes to this bug.