Bug 1768388 - libnm does not show the current destination port for vxlan
Summary: libnm does not show the current destination port for vxlan
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: 8.2
Assignee: Thomas Haller
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-04 10:07 UTC by Quique Llorente
Modified: 2020-04-28 16:53 UTC (History)
9 users (show)

Fixed In Version: NetworkManager-1.22.0-0.2.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:53:15 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:53:41 UTC
freedesktop.org Gitlab NetworkManager/NetworkManager/commit/28110ee3c1e997f837312cfc1c7808dc5c5c0fa3 0 None None None 2019-11-04 10:07:11 UTC

Description Quique Llorente 2019-11-04 10:07:11 UTC
Description of problem:

Using programatically libnm with vxlan support you can correctly set destionation port but it has a an issue with the cache and the port reported is always 0

Version-Release number of selected component (if applicable):

1.20


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

This will be fixed at 

https://gitlab.freedesktop.org/NetworkManager/NetworkManager/commit/28110ee3c1e997f837312cfc1c7808dc5c5c0fa3

Comment 3 Vladimir Benes 2020-01-31 15:42:00 UTC
test case added to read vxlan params for both dbus and nmclient interfaces

Comment 5 errata-xmlrpc 2020-04-28 16:53:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.