Bug 176845 - pnmnorm crashes on certain input
pnmnorm crashes on certain input
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-03 12:35 EST by Vlado Potisk
Modified: 2013-07-02 19:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 08:35:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pnmnorm input file - gzipped (2.30 KB, application/octet-stream)
2006-01-03 12:40 EST, Vlado Potisk
no flags Details

  None (edit)
Description Vlado Potisk 2006-01-03 12:35:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I have found error messages of this type in the log:
kernel: pnmnorm[21917] trap divide error rip:40107f rsp:7fffff8ac400 error:0

They were quite rare, occurring once a week or even less frequenly. I made a wrapper script to find out more and waited for the next crash

The pnmnorm is called as ppmnorm (which is a link to pnmnorm) from the vidwhacker xscreensaver program and sometimes it crashes. I have captured the input file causing the crash. Hope it helps.


Version-Release number of selected component (if applicable):
netpbm-progs-10.28-1.FC4.2

How reproducible:
Always

Steps to Reproduce:
1. pnmnorm < problem.ppm > output.rpm
  

Actual Results:  Floating point exception

Expected Results:  output.ppm file should have been written

Additional info:
Comment 1 Vlado Potisk 2006-01-03 12:40:48 EST
Created attachment 122719 [details]
pnmnorm input file - gzipped

This is the file triggering the crash. It is gzipped, the original file is over
2MB big.
Comment 2 Jindrich Novy 2006-01-04 05:51:52 EST
The bug is caused by division by zero in the normalization function. I tested it
with the latest upstream version we have in devel and it's fixed there (pnmnorm
displays a warning).

I'll close this after FC4 updates are released.
Comment 3 Jindrich Novy 2006-01-04 08:30:34 EST
Fixed in CVS.
Comment 4 Fedora Update System 2006-01-05 16:54:49 EST
From User-Agent: XML-RPC

netpbm-10.31-1.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.