Bug 176856 - loading of mptbase driver during loader section of anaconda takes ~10 minutes on a x86_64 (viper) using i386 disks
loading of mptbase driver during loader section of anaconda takes ~10 minutes...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.7
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-03 15:25 EST by Suzanne Hillman
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:49:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2006-01-03 15:25:10 EST
Description of problem:
The loading time of the mptbase driver during the module loading section of
anaconda takes ~10 minutes (and fails to load), but only if you're trying to use
the RHEL3-U7-re1220.0 i386 tree for installation purposes, on an x86_64
(specifically, and possibly only, a viper). (happens with a CD install, pxe
install, and a cd boot disk but NFS-based install)

There are errors to the third virtual terminal (alt f3), saying: 
"/tmp/mbtscsih.o: init_module:
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
* failed to insert /tmp/mbtscsih.o"

Aaaaaand, it doesn't see the SCSI drive when one gets to the point of trying to
partition things.

Version-Release number of selected component (if applicable):
Based on what's in the tree, probably anaconda-9.1.6.9-1.RHEL.i386.rpm

(it's RHEL3 U7 re1220.0)

How reproducible:
Always, it seems.

Steps to Reproduce:
1. Get a Viper and an i386 install boot disk (pxe boot does it, too).
2. Boot off the boot disk.
  
Actual results:
Watch it try, and fail, to load the mptbase module.

Expected results:
Module succeeds in loading, and the SCSI disk is visible.

Additional info:
Fairly sure that one is supposed to be able to do a i386 install on a x86_64 box...
Comment 1 RHEL Product and Program Management 2007-10-19 14:49:17 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.