Bug 1768564 - [IPI Baremetal] baremetal: IPI baremetal image download broken by appended checksum query string
Summary: [IPI Baremetal] baremetal: IPI baremetal image download broken by appended ch...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.3.0
Assignee: Steven Hardy
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-04 17:48 UTC by Steven Hardy
Modified: 2020-02-06 11:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:10:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer issues 2617 'None' closed baremetal: Openstack checksum changes break deployment 2020-09-24 04:02:48 UTC
Github openshift installer pull 2618 'None' closed Bug 1768564: baremetal: Fix image URL generation 2020-09-24 04:02:48 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:10:51 UTC

Description Steven Hardy 2019-11-04 17:48:57 UTC
Description of problem:

https://github.com/openshift/installer/pull/2528 landed and it's broken IPI baremetal deployments, which also consume the openstack image URL.

How reproducible:

Always

Steps to Reproduce:
1. Attempt to deploy with platform: baremetal
2. Note that deployment fails because of a malformed URL in the terraform variables (and later the machine providerSpec)

Actual results:

level=error msg="  31: resource \"ironic_deployment\" \"openshift-master-deployment\" {"
level=error
level=error
level=error
level=error msg="Error: Bad request with: [PUT http://172.22.0.2:6385/v1/nodes/10a93fa8-edc9-4e8a-80ee-aedaca83ec4c/states/provision], error message: {\"error_message\": \"{\\\"faultcode\\\": \\\"Client\\\", \\\"faultstring\\\": \\\"Failed to validate deploy or power info for node 10a93fa8-edc9-4e8a-80ee-aedaca83ec4c. Error: Validation of image href http://172.22.0.2/images/rhcos-43.81.20191028.2-openstack.x86_64.qcow2?sha256=7afab7e1aee1fba259103629cfbba03c887fc490d091ff9f99fe64c0590d4e82/rhcos-43.81.20191028.2-compressed.x86_64.qcow2?sha256=7afab7e1aee1fba259103629cfbba03c887fc490d091ff9f99fe64c0590d4e82 failed, reason: Got HTTP code 301 instead of 200 in response to HEAD request.\\\", \\\"debuginfo\\\": null}\"}"
level=error
level=error msg="  on ../../../tmp/openshift-install-556906490/masters/main.tf line 31, in resource \"ironic_deployment\" \"openshift-master-deployment\":"
level=error msg="  31: resource \"ironic_deployment\" \"openshift-master-deployment\" {"
level=error
level=error
level=fatal msg="failed to fetch Cluster: failed to generate asset \"Cluster\": failed to create cluster: failed to apply using Terraform"


Expected results:

Deployment should work as before the checksum was added

Comment 3 Sasha Smolyak 2019-12-10 14:49:53 UTC
The BM deployment passed on 4.3.0-0.ci-2019-12-05-183852 version. Verified

Comment 5 errata-xmlrpc 2020-01-23 11:10:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.