Bug 176890 - stardict fails to build in rawhide
stardict fails to build in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: stardict (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Mayberry
:
Depends On:
Blocks: mbt3blocker
  Show dependency treegraph
 
Reported: 2006-01-03 20:51 EST by Jesse Keating
Modified: 2013-01-09 21:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-12 22:48:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build failure log (78.28 KB, text/plain)
2006-01-03 20:51 EST, Jesse Keating
no flags Details
Patch to allow compilation using gcc 4.1 (287 bytes, patch)
2006-01-09 02:04 EST, Tim Mayberry
no flags Details | Diff

  None (edit)
Description Jesse Keating 2006-01-03 20:51:42 EST
Please see attached log.  Build fails on ppc64
Comment 1 Jesse Keating 2006-01-03 20:51:42 EST
Created attachment 122742 [details]
build failure log
Comment 2 Leon Ho 2006-01-09 01:12:29 EST
Thanks Jesse, will have one of us to look into it.
Comment 3 Tim Mayberry 2006-01-09 02:04:49 EST
Created attachment 122937 [details]
Patch to allow compilation using gcc 4.1
Comment 4 Tim Mayberry 2006-01-09 02:12:37 EST
Sorry forgot to add, patch is against upstream sources but it should apply, if
it doesn't let me know. The reason this patch is needed is that gcc is now more
strict about accepting invalid c++ code. see 
https://www.redhat.com/archives/fedora-devel-list/2005-December/msg00256.html
and in particular http://gcc.gnu.org/bugzilla/show_bug.cgi?id=16782
Comment 5 Tim Mayberry 2006-01-10 17:48:53 EST
I sent the patch to the upstream StarDict maintainer Hu Zheng, and this is his
reply:

OK, StarDict-2.4.6 have already sloved this problem, it will be released
soon.
Thank you for your patch :)

I'm not sure how soon is "soon" but if a new StarDict package is not released
within a week I'll fix the package. If this is more urgent let me know.
Comment 6 Leon Ho 2006-01-12 22:48:06 EST
I have included the patch into rawhide and rebuilt as well. Thanks Tim.

Note You need to log in before you can comment on or make changes to this bug.