Bug 1769046 - build of rubygem-docile for EPEL 8
Summary: build of rubygem-docile for EPEL 8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: rubygem-docile
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Troy Dawson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-05 20:11 UTC by Breno
Modified: 2020-02-01 01:54 UTC (History)
1 user (show)

Fixed In Version: rubygem-docile-1.1.5-9.el8.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-01 01:54:05 UTC
Type: Bug


Attachments (Terms of Use)

Description Breno 2019-11-05 20:11:46 UTC
Hi,

I would like to ask a build of rubygem-docile for EPEL 8.

Would you mind requesting the branches and build them?
This package is specially important for puppet, also filed (#1748525).

Please, let me know if I can be of any help.

Thank you very much.

- Breno

Comment 1 Troy Dawson 2019-11-05 20:57:43 UTC
This package needs a few other packages before it can build.  Have you opened bugs yet for the following?
rubygem-mime-types
rubygem-redcarpet
rubygem-yard

Comment 3 Troy Dawson 2019-11-06 14:41:10 UTC
I was looking at the bugzilla for puppet in EPEL8, and then looking at the dependencies of the puppet we currently have in Fedora.  I don't see anywhere a dependency for rubygem-docile.

Would you mind walking through the dependency of puppet to show why you need rubygem-docile in epel8.

Comment 4 Breno 2019-11-06 14:53:01 UTC
Hi Troy,

Right now I am working on the build of puppet 6 for EPEL 8.
That is how rubygem-docile would help.

I hope you it's not an issue for you.

Thanks.

Comment 5 Troy Dawson 2019-11-06 16:46:12 UTC
Nope, not an issue.
It's just that sometime the rubygem dependency tree's get rather big, and if we're working on a package that isn't needed, it's alot of work for no real reason.  I was just checking.

Comment 6 Breno 2019-11-06 16:56:39 UTC
Oh, sure Troy. Thanks for having this care.

Comment 7 Fedora Update System 2020-01-16 20:02:24 UTC
FEDORA-EPEL-2020-2374df6d9a has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-2374df6d9a

Comment 8 Fedora Update System 2020-01-16 23:24:20 UTC
rubygem-docile-1.1.5-9.el8.1 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-2374df6d9a

Comment 9 Fedora Update System 2020-02-01 01:54:05 UTC
rubygem-docile-1.1.5-9.el8.1 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.