Bug 176910 - cairo fails to build in rawhide
cairo fails to build in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Carl Worth
:
Depends On:
Blocks: FC5Target 164374 167383 mbt3blocker
  Show dependency treegraph
 
Reported: 2006-01-04 02:35 EST by Jesse Keating
Modified: 2013-01-09 21:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 14:18:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build failure log (14.65 KB, text/plain)
2006-01-04 02:35 EST, Jesse Keating
no flags Details
Remove spurious definitions (965 bytes, patch)
2006-01-04 12:45 EST, Carl Worth
no flags Details | Diff
Patch to cairo spec to add build fix and embedded bitmap patches (1.12 KB, patch)
2006-01-16 20:57 EST, Tim Mayberry
no flags Details | Diff
Embedded bitmap patch (1.40 KB, patch)
2006-01-16 20:58 EST, Tim Mayberry
no flags Details | Diff
Build fix patch (749 bytes, patch)
2006-01-16 20:58 EST, Tim Mayberry
no flags Details | Diff

  None (edit)
Description Jesse Keating 2006-01-04 02:35:51 EST
Please see attached log.  Build fails on ppc64.  Looks like assembler stuff maybe.
Comment 1 Jesse Keating 2006-01-04 02:35:51 EST
Created attachment 122756 [details]
build failure log
Comment 2 Carl Worth 2006-01-04 12:45:35 EST
Created attachment 122769 [details]
Remove spurious definitions

This looks like a bug that was in 1.0.2 but that only shows up with more recent
versions of binutils. Here is the patch that already exists in cairo CVS for
this bug.

2005-11-21  Carl Worth	<cworth@cworth.org>

	* src/pixman-remap.h: Remove duplicate definitions of
	pixman_color_to_pixel and pixman_composite which break the
	build with very recent binutils.
Comment 3 Tim Mayberry 2006-01-16 20:57:11 EST
Created attachment 123279 [details]
Patch to cairo spec to add build fix and embedded bitmap patches

Patch to cairo spec file to add two patches, one to fix cairo build with gcc
version in Rawhide, the other to support the embedded bitmap fontconfig option
that is needed for bug 164374 and bug 167383.
Comment 4 Tim Mayberry 2006-01-16 20:58:04 EST
Created attachment 123281 [details]
Embedded bitmap patch
Comment 5 Tim Mayberry 2006-01-16 20:58:55 EST
Created attachment 123282 [details]
Build fix patch
Comment 6 Tim Mayberry 2006-01-17 20:45:30 EST
Somewhat related, I just tried to build cairo using mock and In order for cairo
to be built with the Xlib backend I had to add libX11-devel to the BuildRequires.  
Comment 7 Ray Strode [halfline] 2006-01-31 11:14:59 EST
Hey guys,

I'm building this into rawhide.  I want to make sure this doesn't get forgot
about  and miss test3.

If there's problems with the patch we'll still have plenty of time to fix things up.

Should be in tomorrow's rawhide. Let me know if the changes work.
Comment 8 Tim Mayberry 2006-02-07 00:37:03 EST
Sorry for the delay, just letting you know that the changes do indeed work.
Thank you.

Note You need to log in before you can comment on or make changes to this bug.