Bug 176919 - rpmbuild: rpmio.c:2863: Fdopen: Assertion `fd && fd->magic == 0x04463138' failed
Summary: rpmbuild: rpmio.c:2863: Fdopen: Assertion `fd && fd->magic == 0x04463138' failed
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-04 12:18 UTC by Dave Mitchell
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-19 20:43:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Mitchell 2006-01-04 12:18:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
While trying to build a development version of ghostscript (required by another package):

# rpmbuild --rebuild http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/ghostscript-8.15.1-3.1.src.rpm
Installing http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/ghostscript-8.15.1-3.1.src.rpm
rpmbuild: rpmio.c:2863: Fdopen: Assertion `fd && fd->magic == 0x04463138' failed.
Aborted
#

Version-Release number of selected component (if applicable):
rpm-build-4.4.1-22

How reproducible:
Always

Steps to Reproduce:
as above

Actual Results:  as above

Expected Results:  shouldn't have died with assertion failure

Additional info:

Comment 1 Jeff Johnson 2006-01-06 11:37:55 UTC
Yep.

So do this instead
    rpm -ivh http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/
ghostscript-8.15.1-3.1.src.rpm
    rpmbuild -bb /usr/src/redhat/SPECS/ghostscript.spec

Comment 2 Dave Mitchell 2006-01-10 21:41:23 UTC
So, because there happens to be a workaround, the fact that rpmbuild fails an
internal assertion isn't a bug ???

Comment 3 Jeff Johnson 2006-01-19 20:43:15 UTC
Yes, you have a workaround, use that instead.

Deferred until whenever (if that floats your boat instead).


Note You need to log in before you can comment on or make changes to this bug.