Bug 1769303 - Creation of a VM with in-page VM Wizard fails due to mutatevirtualmachines.example.com request denial
Summary: Creation of a VM with in-page VM Wizard fails due to mutatevirtualmachines.ex...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Marek Libra
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-06 11:00 UTC by Radim Hrazdil
Modified: 2020-01-23 11:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:11:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
VM YAML (1.72 KB, text/plain)
2019-11-06 11:00 UTC, Radim Hrazdil
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3281 0 'None' closed Bug 1769303: kubevirt: fix type of PVC volumeModes 2020-09-11 11:33:06 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:11:34 UTC

Description Radim Hrazdil 2019-11-06 11:00:58 UTC
Created attachment 1633244 [details]
VM YAML

Description of problem:
Creation of a VM with in-page VM Wizard fails due to the following error:

admission webhook "mutatevirtualmachines.example.com" denied the request: v1.VirtualMachine.Spec: v1.VirtualMachineSpec.DataVolumeTemplates: []v1alpha1.DataVolume: v1alpha1.DataVolume.Spec: v1alpha1.DataVolumeSpec.PVC: v1.PersistentVolumeClaimSpec.AccessModes: []v1.PersistentVolumeAccessMode: decode slice: expect [ or n, but found ", error found in #10 byte of ...|ssModes":"ReadWriteM|..., bigger context ...|"testurl-rootdisk"},"spec":{"pvc":{"accessModes":"ReadWriteMany","resources":{"requests":{"storage":|...



Version-Release number of selected component (if applicable):
cluster with version 4.3.0-0.nightly-2019-10-29-140935
UI running locally from current openshift/console master branch

How reproducible:
100%

Steps to Reproduce:
1. Create a VM via VM Wizard, for exact config see the attached VM yaml
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Marek Libra 2019-11-06 11:50:02 UTC
How to fix: after redesign of the wizard, the DV/PVC accessModes is provided with just a single value instead of wrapping it into an array ("[]").

Comment 3 Radim Hrazdil 2019-11-29 10:14:51 UTC
Verified 4.3.0-0.nightly-2019-11-21-122827

Comment 5 errata-xmlrpc 2020-01-23 11:11:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.