Bug 1769325 - VM Wizard preselects a VM Template option
Summary: VM Wizard preselects a VM Template option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.3.0
Assignee: Marek Libra
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-06 11:59 UTC by Radim Hrazdil
Modified: 2020-01-23 11:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:11:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3304 0 'None' 'closed' 'Bug 1769325: kubevirt: Do not preselect any user template' 2019-11-25 02:56:04 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:11:34 UTC

Description Radim Hrazdil 2019-11-06 11:59:57 UTC
Description of problem:
When the new in-page VM Wizard is opened, there is a preselected VM Template field.
Always the first template in alphabetical order is selected.

Since Template field is not required, it seems odd to preselect anything and the field should be empty on page load.  

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-10-29-140935
UI running locally with current master (commit b6c5ed03d2280464e26e0a015e551e3cd2310ae4)


How reproducible:
100%

Steps to Reproduce:
1. open Wizard
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Guohua Ouyang 2019-11-25 03:05:19 UTC
verified the bug on 4.3.0-0.nightly-2019-11-21-122827

Comment 4 errata-xmlrpc 2020-01-23 11:11:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.