Bug 176933 - LTC20454-i386 12/27 boot.iso fails
LTC20454-i386 12/27 boot.iso fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-04 10:22 EST by IBM Bug Proxy
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-04 18:45:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2006-01-04 10:22:59 EST
LTC Owner is: gjlynx@us.ibm.com
LTC Originator is: krisw@us.ibm.com


Problem description:

I downloaded the 12/27 boot.iso file for i386 on 2 different systems and 
burned 2 CD's.  Both fail the same after I select "linux askmethod vnc" for 
the install method.  First they pause for about three minutes, then the 
following.  A boot.iso CD from 12/16 works fine on the same system.
call trace:
[<c0205928>] tty_ioctl+0x30b/0x361
[<c020566d>] tty_ioctl+0x0/0361
[<c0160dc6>] do_ioctl+0x3a/0x49
[<c0160fd1>] vfs_ioctl+0x15e/0x16c
[<c0161027>] sys_ioctl+0x48/0x61
[<c0102d79>] syscall_call+0x7/0xb

code:

89 c1 53 b8 00 f0 ff ff 89 ca 21 e0 81 c2 00 02 00 00 19 db 39 50 18 83 db 00 
ba f2 ff ff ff 85 db 75 21 31 db 31 c0 66 8b 14 19 <66> 89 93 e0 d4 2d c0 83 
c3 02 81 fb 00 02 00 00 75 e8 e8 cb fe

If this is a customer issue, please indicate the impact to the customer:
  Can't install via linux askmethod vnc on i386.

Hardware Environment
    Machine type (p650, x235, SF2, etc.): x335

Is this reproducible?  Yes
    If so, how long does it (did it) take to reproduce it? 10 minutes
    Describe the steps:

1. Download and burn the boot.iso file from:
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/images

2. Put the CD in the system to be installed and reboot or power off/on.

3. When the screen prompts for the install method, type "linux askmethod vnc"
and enter.  

Is the system (not just the application) hung? Yes
    If so, describe how you determined this: Screen is frozen; must power 
off/on to continue.

Did the system produce an OOPS message on the console?  See description above.
 
Is the system sitting in a debugger right now?  No.

Similar problem with the 12/28 x84_64 boot.iso using both "linux askmethod 
vnc" and "linux askmethod":
Call trace:
ffffffff8025bf2e fvt_ioctl+5161 ffffffff80256ae4 tty_ioctl+3237
ffffffff801e22f2 avc_has_perm+70 ffffffff801e29a4 inode_has_perm+86
ffffffff8016b4cb poison_obj+38   ffffffff8016b8ef cache_free_debugcheck+602
ffffffff801e6cd1 selinux_file_ioctl+663  ffffffff80198a29 do_ioctl+85
ffffffff80198c8a vfs_ioctl+587   ffffffff80198cfc sys_ioctl+89
ffffffff8010f8de system_call+126
code: 66 89 91 20 c3 35 80 48 83 c1 02 48 81 f9 00 02 00 00 75 e6
RIP: ffffffff8025d65d con_set_trans_new+55
RSP: ffffffff81003e41fcb8
CR2: ffffffff8035c320
install exited abnormally - received signal 9

Using an x86_64 boot.iso from 1/3 I am not getting the same thing as described 
previously, but it just gets to "loading initrd.img .. " and hangs. This isn't 
getting as far as the previous problem.
Comment 1 Dave Jones 2006-01-04 18:45:27 EST
fixed several days ago.

it's fairly pointless reporting bugs in week old trees when the kernel is
changing daily without trying to reproduce with the current one.
Comment 2 IBM Bug Proxy 2006-01-05 10:21:15 EST
---- Additional Comments From krisw@us.ibm.com  2006-01-05 10:22 EDT -------
This bug was written last week but not forwarded to RH until this week; 
probably due to holidays.  At the time it was written on the current build 
after trying several days in a row.  Shouldn\'t installation be tested? 
Comment 3 IBM Bug Proxy 2006-01-06 13:36:53 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ASSIGNED                    |FIXEDAWAITINGTEST
         Resolution|                            |FIX_BY_DISTRO




------- Additional Comments From krisw@us.ibm.com  2006-01-06 13:39 EDT -------
Today I successfully installed the 1/5/05 x86_64 rawhide using the boot.iso 
with no problem.  I don\'t have an i386 system available right now to try, but 
will assume that boot.iso also works. 

Note You need to log in before you can comment on or make changes to this bug.