Bug 1769375 - should add download deployment resource limits
Summary: should add download deployment resource limits
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1769302
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-06 13:44 UTC by Samuel Padgett
Modified: 2019-11-21 09:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the console CLI downloads deployment did not set a resource request. We've added resource requests values for CPU and memory to the deployment. This prevents a cluster component from running as best effort pods.
Clone Of: 1769302
Environment:
Last Closed: 2019-11-21 09:17:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console-operator pull 341 'None' 'closed' 'Bug 1769375: manifests: add resource requests to downloads pod' 2019-11-20 21:12:16 UTC
Red Hat Product Errata RHBA-2019:3875 None None None 2019-11-21 09:18:03 UTC

Description Samuel Padgett 2019-11-06 13:44:53 UTC
+++ This bug was initially created as a clone of Bug #1769302 +++

Description of problem:
should add download deployment resource limits for 4.1


Version-Release number of selected component (if applicable):
4.1.0-0.nightly-2019-11-05-091918

How reproducible:


Steps to Reproduce:
1. oc get deploy download -n openshift-console -o yaml |grep "resources:" -A 3
2.
3.

Actual results:
no this kind of resource limit

Expected results:
 - resources:
            requests:
              cpu: 10m
              memory: 50Mi

Additional info:

--- Additional comment from Samuel Padgett on 2019-11-06 13:42:43 UTC ---

Targeting to 4.2.z for validation the previous fix to 4.2, then we'll clone to backport.

--- Additional comment from Samuel Padgett on 2019-11-06 13:44:02 UTC ---

No doc update as this was previously fixed in 4.2.0.

Comment 2 shahan 2019-11-12 05:46:13 UTC
Now have the request limit for download deployment.
things like:
      containers:
        - resources:
            requests:
              cpu: 10m
              memory: 50Mi
Verify this bug
4.1.0-0.nightly-2019-11-11-220054

Comment 4 errata-xmlrpc 2019-11-21 09:17:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3875


Note You need to log in before you can comment on or make changes to this bug.