Bug 176947 - ICE in referenced_var_lookup when compiling with gfortran
ICE in referenced_var_lookup when compiling with gfortran
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-04 12:01 EST by Alexander Täschner
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version: 4.1.0-0.14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 13:52:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Täschner 2006-01-04 12:01:51 EST
The following code produces an ICE when compiled with gfortran using the -O and
-fno-automatic flags together. This bug exists in gfortran 4.1.0-0.12, but not
in 4.0.2-8.

$ cat hwhew2.f
      SUBROUTINE HWHEW2(NPART)
      IMPLICIT NONE
      COMPLEX PT5,ZT,ZI
      DOUBLE PRECISION WRN(7)
      INTEGER J,I,NPART,IP1

      DO 11 I=1,NPART-1
      IP1=I+1
      DO 11 J=IP1,NPART

      IF(WRN(I).LT.0) ZT=ZT*ZI
      IF(WRN(J).LT.0) ZT=ZT*ZI

      PT5=CMPLX(.5,0.)

   11 CONTINUE

      RETURN
      END
$ gfortran -c -O -fno-automatic hwhew2.f
hwhew2.f: In function 'hwhew2':
hwhew2.f:1: internal compiler error: in referenced_var_lookup, at tree-dfa.c:591
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Comment 1 Alexander Täschner 2006-01-09 13:52:11 EST
Seems to be fixed in 4.1.0-0.14. I hope it will not reappear in a new version.

Note You need to log in before you can comment on or make changes to this bug.