Bug 176950 - wxGTK support for databases (wxODBC) missing
wxGTK support for databases (wxODBC) missing
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: wxGTK (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Miller
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-04 12:14 EST by Nicola Soranzo
Modified: 2009-07-02 08:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-15 13:26:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicola Soranzo 2006-01-04 12:14:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The wxWidgets/GTK toolkit has a class for database abstraction via ODBC, but this class is not included in the package. It'd be nice to have it, maybe in a separate subpackage.

To compile the class --with-odbc should be added to configure.
Also it requires unixODBC (or iODBC, but iODBC is neither in Core nor in Extras).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Compile a wxGTK program that need the ODBC classes.


Actual Results:  The program is compiled, but linking fails.

Additional info:

Class documentation:
http://www.wxwidgets.org/manuals/2.6.2/wx_odbcoverview.html

Other information here:
http://wiki.wxwidgets.org/wiki.pl?ODBC
Comment 1 Matthew Miller 2006-01-04 13:40:15 EST
Sounds reasonable, especially since unixODBC is right there in core.
Comment 2 Matthew Miller 2006-02-06 12:27:08 EST
I'd like some opinions from people on whether this should be a subpackage or
integrated into the main RPM. I don't want to have a crazed profusion of
subpackages (especially when the prereqs are something that reasonably can be
expected to be on the system of someone who might want wxGTK). But does unixODBC
warrant an exception?
Comment 3 Nicola Soranzo 2006-03-15 08:17:14 EST
Matthew, is wxGTK 2.6.3 going out with or without wxODBC?
Comment 4 Matthew Miller 2006-03-15 08:31:29 EST
I was thinking I'd add it at that point, probably as a subpackage.
Comment 5 Matthew Miller 2006-03-21 14:46:23 EST
Currently with rc2, I get this build failure:


./src/common/db.cpp: In member function 'bool wxDb::Open(const wxString&, void*,
 bool)':
./src/common/db.cpp:848: error: ambiguous overload for 'operator=' in '((wxDb*)t
his)->wxDb::outConnectionStr = outConnectBuffer'


(Haven't investigated at all; just got that error and figured I'd mention it
here in case someone wants to jump in with a known fix.)
Comment 6 Matthew Miller 2006-03-21 14:49:33 EST
Hmmm, okay -- quick googling indicates that this is a problem with wxODBC and
Unicode, or at least was in 2004.
Comment 7 Matthew Miller 2006-03-21 15:01:03 EST
Talking to myself.... here's the upstream bug:

https://sourceforge.net/tracker/?func=detail&atid=109863&aid=1163141&group_id=9863
Comment 8 Matthew Miller 2006-04-13 17:11:33 EDT
Building in Fedora Extras devel. Since it's currently broken and has been for so
long, I'll build for FC5 as soon as I hear positive feedback or on Monday,
whichever comes first.
Comment 9 Matthew Miller 2006-04-18 22:56:27 EDT
Comment #8 is misplaced; sorry. Please ignore that; this is still waiting on the
upstream bug.

I'm going to mark this deferred for now. If someone comes up with a fix, please
give me a jab and I'll revisit. Thanks!
Comment 10 Matthew Miller 2007-04-15 12:58:52 EDT
Upstream bug not marked as fixed, but trying again with version 2.8.3 just to see.
Comment 11 Matthew Miller 2007-04-15 13:26:15 EDT
Still broken upstream.

Note You need to log in before you can comment on or make changes to this bug.