Bug 176960 - Pup will remove packages to be updated
Summary: Pup will remove packages to be updated
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-04 18:47 UTC by Luya Tshimbalanga
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-05 02:18:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Luya Tshimbalanga 2006-01-04 18:47:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Pup removes packages set to be updated and won't install them. That happened on January 4th when updating rawhide. The issue is a critical because that behavior may totally make Fedora completely unbootable if doing critical updates.

Version-Release number of selected component (if applicable):
pup-0.1.9-1

How reproducible:
Always

Steps to Reproduce:
1. Run pup
2. update packages
3. reboot
  

Actual Results:  Package to be updated are removed.

Expected Results:  Packages should be updated.

Additional info:

Comment 1 Jeremy Katz 2006-01-05 02:18:19 UTC
Based on the conversation we had on IRC, I think this was due to bum SELinux
policy yesterday.

Comment 2 David Lawrence 2006-06-28 01:43:09 UTC
Moving component to pirut. Sorry for the spam.


Note You need to log in before you can comment on or make changes to this bug.