Bug 1769647 - Description is empty when oc explain authentication.operator.openshift.io
Summary: Description is empty when oc explain authentication.operator.openshift.io
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.3.0
Assignee: Standa Laznicka
QA Contact: xiyuan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-07 05:28 UTC by xiyuan
Modified: 2020-01-23 11:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:11:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-authentication-operator pull 214 'None' closed Bug 1769647: Use openshift/api vendored config CRD 2020-04-02 02:52:35 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:11:49 UTC

Description xiyuan 2019-11-07 05:28:00 UTC
Description of problem:
Description is empty when oc explain authentication.operator.openshift.io


Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-11-06-215135

How reproducible:
Always

Steps to Reproduce:
#### v4.3
$ oc explain authentication --api-version='operator.openshift.io/v1'
KIND:     Authentication
VERSION:  operator.openshift.io/v1

DESCRIPTION:
     <empty>

Comment 2 xiyuan 2019-11-08 05:16:16 UTC
One minor issue: It is empty for spec and status field for authentication.operator.openshift.io, while it is not for authentication.config.openshift.io. Will any further modification be done? Thanks.

$ oc explain authentication --api-version='operator.openshift.io/v1'
KIND:     Authentication
VERSION:  operator.openshift.io/v1

DESCRIPTION:
     Authentication provides information to configure an operator to manage
     authentication.

FIELDS:
   apiVersion	<string>
     APIVersion defines the versioned schema of this representation of an
     object. Servers should convert recognized schemas to the latest internal
     value, and may reject unrecognized values. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#resources

   kind	<string>
     Kind is a string value representing the REST resource this object
     represents. Servers may infer this from the endpoint the client submits
     requests to. Cannot be updated. In CamelCase. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#types-kinds

   metadata	<Object>
     Standard object's metadata. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#metadata

   spec	<Object> -required-

   status	<Object>

$ oc explain authentication
KIND:     Authentication
VERSION:  config.openshift.io/v1

DESCRIPTION:
     Authentication specifies cluster-wide settings for authentication (like
     OAuth and webhook token authenticators). The canonical name of an instance
     is `cluster`.

FIELDS:
   apiVersion	<string>
     APIVersion defines the versioned schema of this representation of an
     object. Servers should convert recognized schemas to the latest internal
     value, and may reject unrecognized values. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#resources

   kind	<string>
     Kind is a string value representing the REST resource this object
     represents. Servers may infer this from the endpoint the client submits
     requests to. Cannot be updated. In CamelCase. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#types-kinds

   metadata	<Object>
     Standard object's metadata. More info:
     https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#metadata

   spec	<Object> -required-
     spec holds user settable values for configuration

   status	<Object>
     status holds observed values from the cluster. They may not be overridden.

Comment 3 Standa Laznicka 2019-11-12 15:41:09 UTC
That description being empty is ok for now

Comment 7 errata-xmlrpc 2020-01-23 11:11:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.