Bug 1769835 - Request to rebuild qt-creator for RHEL 8.1
Summary: Request to rebuild qt-creator for RHEL 8.1
Keywords:
Status: ON_QA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: qt-creator
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Johansen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-07 15:16 UTC by Jens Kretschmer
Modified: 2019-12-07 03:04 UTC (History)
7 users (show)

Fixed In Version: qt-creator-4.9.2-3.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-26 14:57:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Jens Kretschmer 2019-11-07 15:16:14 UTC
Description of problem:
Currently installing qt-creator on RHEL 8.1 requires a downgrade of 4 packages. This results in multiple error messages being printed if an update is performed.

Version-Release number of selected component (if applicable):
qt-creator-4.9.2-2.el8.x86_64

How reproducible:
always reproducible

Steps to Reproduce:
# dnf install qt-creator
# dnf update

Actual results:
# dnf install qt-creator
Updating Subscription Management repositories.
Last metadata expiration check: 0:02:24 ago on Thu Nov  7 15:53:56 2019.
Dependencies resolved.
=========================================================================================================
 Package           Arch   Version                                 Repository                        Size
=========================================================================================================
Installing:
 qt-creator        x86_64 4.9.2-2.el8                             epel                              20 M
Installing dependencies:
 qt-creator-data   noarch 4.9.2-2.el8                             epel                             1.4 M
 qt5-rpm-macros    noarch 5.11.1-2.el8                            rhel-8-for-x86_64-appstream-rpms  12 k
 clang-libs        x86_64 7.0.1-1.module+el8+2560+c32c7af1        rhel-8-for-x86_64-appstream-rpms  16 M
 qt5-qtbase-devel  x86_64 5.11.1-7.el8                            rhel-8-for-x86_64-appstream-rpms 4.3 M
 mesa-libEGL-devel x86_64 19.1.4-2.el8                            rhel-8-for-x86_64-appstream-rpms  47 k
Installing weak dependencies:
 compiler-rt       x86_64 8.0.1-1.module+el8.1.0+3866+6be7f4d8    rhel-8-for-x86_64-appstream-rpms 3.3 M
 libomp            x86_64 8.0.1-1.module+el8.1.0+3866+6be7f4d8    rhel-8-for-x86_64-appstream-rpms 330 k
Downgrading:
 mesa-filesystem   x86_64 18.3.1-5.el8_0                          rhel-8-for-x86_64-appstream-rpms  32 k
 mesa-dri-drivers  x86_64 18.3.1-5.el8_0                          rhel-8-for-x86_64-appstream-rpms 7.3 M
 mesa-libxatracker x86_64 18.3.1-5.el8_0                          rhel-8-for-x86_64-appstream-rpms 1.8 M
 llvm-libs         x86_64 7.0.1-3.module+el8.0.0+3181+ec021930    rhel-8-for-x86_64-appstream-rpms  17 M

Transaction Summary
=========================================================================================================
Install    8 Packages
Downgrade  4 Packages

Total download size: 71 M
Is this ok [y/N]: y
Downloading Packages:
(1/12): mesa-filesystem-18.3.1-5.el8_0.x86_64.rpm                         53 kB/s |  32 kB     00:00    
(2/12): mesa-libxatracker-18.3.1-5.el8_0.x86_64.rpm                      1.0 MB/s | 1.8 MB     00:01    
(3/12): mesa-dri-drivers-18.3.1-5.el8_0.x86_64.rpm                       2.3 MB/s | 7.3 MB     00:03    
(4/12): qt-creator-data-4.9.2-2.el8.noarch.rpm                           3.0 MB/s | 1.4 MB     00:00    
(5/12): qt5-rpm-macros-5.11.1-2.el8.noarch.rpm                            18 kB/s |  12 kB     00:00    
(6/12): llvm-libs-7.0.1-3.module+el8.0.0+3181+ec021930.x86_64.rpm        3.5 MB/s |  17 MB     00:04    
(7/12): qt-creator-4.9.2-2.el8.x86_64.rpm                                4.3 MB/s |  20 MB     00:04    
(8/12): qt5-qtbase-devel-5.11.1-7.el8.x86_64.rpm                         2.4 MB/s | 4.3 MB     00:01    
(9/12): mesa-libEGL-devel-19.1.4-2.el8.x86_64.rpm                         67 kB/s |  47 kB     00:00    
(10/12): libomp-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64.rpm          884 kB/s | 330 kB     00:00    
(11/12): compiler-rt-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64.rpm     2.9 MB/s | 3.3 MB     00:01    
(12/12): clang-libs-7.0.1-1.module+el8+2560+c32c7af1.x86_64.rpm          3.6 MB/s |  16 MB     00:04    
---------------------------------------------------------------------------------------------------------
Total                                                                    5.1 MB/s |  71 MB     00:13     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                 1/1 
  Downgrading      : llvm-libs-7.0.1-3.module+el8.0.0+3181+ec021930.x86_64                          1/16 
  Running scriptlet: llvm-libs-7.0.1-3.module+el8.0.0+3181+ec021930.x86_64                          1/16 
  Installing       : libomp-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64                             2/16 
  Installing       : compiler-rt-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64                        3/16 
  Installing       : clang-libs-7.0.1-1.module+el8+2560+c32c7af1.x86_64                             4/16 
  Installing       : mesa-libEGL-devel-19.1.4-2.el8.x86_64                                          5/16 
  Installing       : qt5-rpm-macros-5.11.1-2.el8.noarch                                             6/16 
  Installing       : qt5-qtbase-devel-5.11.1-7.el8.x86_64                                           7/16 
  Installing       : qt-creator-data-4.9.2-2.el8.noarch                                             8/16 
  Installing       : qt-creator-4.9.2-2.el8.x86_64                                                  9/16 
  Downgrading      : mesa-filesystem-18.3.1-5.el8_0.x86_64                                         10/16 
  Downgrading      : mesa-dri-drivers-18.3.1-5.el8_0.x86_64                                        11/16 
  Downgrading      : mesa-libxatracker-18.3.1-5.el8_0.x86_64                                       12/16 
  Running scriptlet: mesa-libxatracker-18.3.1-5.el8_0.x86_64                                       12/16 
  Cleanup          : mesa-dri-drivers-19.1.4-2.el8.x86_64                                          13/16 
  Cleanup          : mesa-libxatracker-19.1.4-2.el8.x86_64                                         14/16 
  Running scriptlet: mesa-libxatracker-19.1.4-2.el8.x86_64                                         14/16 
  Cleanup          : mesa-filesystem-19.1.4-2.el8.x86_64                                           15/16 
  Cleanup          : llvm-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64                         16/16 
  Running scriptlet: llvm-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64                         16/16 
  Verifying        : mesa-filesystem-18.3.1-5.el8_0.x86_64                                          1/16 
  Verifying        : mesa-filesystem-19.1.4-2.el8.x86_64                                            2/16 
  Verifying        : mesa-dri-drivers-18.3.1-5.el8_0.x86_64                                         3/16 
  Verifying        : mesa-dri-drivers-19.1.4-2.el8.x86_64                                           4/16 
  Verifying        : mesa-libxatracker-18.3.1-5.el8_0.x86_64                                        5/16 
  Verifying        : mesa-libxatracker-19.1.4-2.el8.x86_64                                          6/16 
  Verifying        : llvm-libs-7.0.1-3.module+el8.0.0+3181+ec021930.x86_64                          7/16 
  Verifying        : llvm-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64                          8/16 
  Verifying        : qt-creator-4.9.2-2.el8.x86_64                                                  9/16 
  Verifying        : qt-creator-data-4.9.2-2.el8.noarch                                            10/16 
  Verifying        : qt5-rpm-macros-5.11.1-2.el8.noarch                                            11/16 
  Verifying        : clang-libs-7.0.1-1.module+el8+2560+c32c7af1.x86_64                            12/16 
  Verifying        : qt5-qtbase-devel-5.11.1-7.el8.x86_64                                          13/16 
  Verifying        : mesa-libEGL-devel-19.1.4-2.el8.x86_64                                         14/16 
  Verifying        : compiler-rt-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64                       15/16 
  Verifying        : libomp-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64                            16/16 
Installed products updated.

Downgraded:
  mesa-filesystem-18.3.1-5.el8_0.x86_64        mesa-dri-drivers-18.3.1-5.el8_0.x86_64                    
  mesa-libxatracker-18.3.1-5.el8_0.x86_64      llvm-libs-7.0.1-3.module+el8.0.0+3181+ec021930.x86_64     

Installed:
  qt-creator-4.9.2-2.el8.x86_64                                                                          
  compiler-rt-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64                                                
  libomp-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64                                                     
  qt-creator-data-4.9.2-2.el8.noarch                                                                     
  qt5-rpm-macros-5.11.1-2.el8.noarch                                                                     
  clang-libs-7.0.1-1.module+el8+2560+c32c7af1.x86_64                                                     
  qt5-qtbase-devel-5.11.1-7.el8.x86_64                                                                   
  mesa-libEGL-devel-19.1.4-2.el8.x86_64                                                                  

Complete!
# dnf update
Updating Subscription Management repositories.
Last metadata expiration check: 0:10:36 ago on Thu Nov  7 15:53:56 2019.
Error: 
 Problem 1: package qt-creator-4.9.2-2.el8.x86_64 requires libclang.so.7()(64bit), but none of the providers can be installed
  - package qt-creator-4.9.2-2.el8.x86_64 requires libclang.so.7(LLVM_7)(64bit), but none of the providers can be installed
  - package qt-creator-4.9.2-2.el8.x86_64 requires libclangBasic.so.7()(64bit), but none of the providers can be installed
  - package qt-creator-4.9.2-2.el8.x86_64 requires libclangFormat.so.7()(64bit), but none of the providers can be installed
  - package qt-creator-4.9.2-2.el8.x86_64 requires libclangLex.so.7()(64bit), but none of the providers can be installed
  - package qt-creator-4.9.2-2.el8.x86_64 requires libclangRewrite.so.7()(64bit), but none of the providers can be installed
  - package qt-creator-4.9.2-2.el8.x86_64 requires libclangToolingCore.so.7()(64bit), but none of the providers can be installed
  - package qt-creator-4.9.2-2.el8.x86_64 requires libclangToolingInclusions.so.7()(64bit), but none of the providers can be installed
  - cannot install both clang-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64 and clang-libs-7.0.1-1.module+el8+2560+c32c7af1.x86_64
  - cannot install both clang-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64 and clang-libs-7.0.1-1.module+el8.0.0+3181+ec021930.x86_64
  - cannot install the best update candidate for package qt-creator-4.9.2-2.el8.x86_64
  - cannot install the best update candidate for package clang-libs-7.0.1-1.module+el8+2560+c32c7af1.x86_64
 Problem 2: package qt-creator-data-4.9.2-2.el8.noarch requires qt-creator = 4.9.2-2.el8, but none of the providers can be installed
  - package qt-creator-4.9.2-2.el8.x86_64 requires libLLVM-7.so()(64bit), but none of the providers can be installed
  - package qt-creator-4.9.2-2.el8.x86_64 requires libLLVM-7.so(LLVM_7)(64bit), but none of the providers can be installed
  - cannot install both llvm-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64 and llvm-libs-7.0.1-3.module+el8.0.0+3181+ec021930.x86_64
  - cannot install both llvm-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64 and llvm-libs-7.0.1-1.module+el8+2560+c32c7af1.x86_64
  - cannot install the best update candidate for package qt-creator-data-4.9.2-2.el8.noarch
  - cannot install the best update candidate for package llvm-libs-7.0.1-3.module+el8.0.0+3181+ec021930.x86_64
 Problem 3: problem with installed package qt-creator-4.9.2-2.el8.x86_64
  - package qt-creator-4.9.2-2.el8.x86_64 requires libLLVM-7.so()(64bit), but none of the providers can be installed
  - package qt-creator-4.9.2-2.el8.x86_64 requires libLLVM-7.so(LLVM_7)(64bit), but none of the providers can be installed
  - cannot install both llvm-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64 and llvm-libs-7.0.1-3.module+el8.0.0+3181+ec021930.x86_64
  - cannot install both llvm-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64 and llvm-libs-7.0.1-1.module+el8+2560+c32c7af1.x86_64
  - package mesa-dri-drivers-19.1.4-2.el8.x86_64 requires libLLVM-8.so()(64bit), but none of the providers can be installed
  - package mesa-dri-drivers-19.1.4-2.el8.x86_64 requires libLLVM-8.so(LLVM_8)(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package mesa-dri-drivers-18.3.1-5.el8_0.x86_64
 Problem 4: problem with installed package qt-creator-data-4.9.2-2.el8.noarch
  - package qt-creator-data-4.9.2-2.el8.noarch requires qt-creator = 4.9.2-2.el8, but none of the providers can be installed
  - package qt-creator-4.9.2-2.el8.x86_64 requires libLLVM-7.so()(64bit), but none of the providers can be installed
  - package qt-creator-4.9.2-2.el8.x86_64 requires libLLVM-7.so(LLVM_7)(64bit), but none of the providers can be installed
  - cannot install both llvm-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64 and llvm-libs-7.0.1-3.module+el8.0.0+3181+ec021930.x86_64
  - cannot install both llvm-libs-8.0.1-1.module+el8.1.0+3866+6be7f4d8.x86_64 and llvm-libs-7.0.1-1.module+el8+2560+c32c7af1.x86_64
  - package mesa-libxatracker-19.1.4-2.el8.x86_64 requires libLLVM-8.so()(64bit), but none of the providers can be installed
  - package mesa-libxatracker-19.1.4-2.el8.x86_64 requires libLLVM-8.so(LLVM_8)(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package mesa-libxatracker-18.3.1-5.el8_0.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)


Expected results:
installing qt-creator does not require a downgrade of packages. "dnf update" executes without errors.


Additional info:

Comment 1 Fedora Update System 2019-11-08 09:12:49 UTC
FEDORA-EPEL-2019-c391610968 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-c391610968

Comment 2 Fedora Update System 2019-11-10 00:15:51 UTC
qt-creator-4.9.2-3.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-c391610968

Comment 3 Fedora Update System 2019-11-26 14:57:21 UTC
qt-creator-4.9.2-3.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.

Comment 4 Afk 2019-12-02 11:01:52 UTC
Not resolved.

4.9.2-3 still requires LLVM_7:

Problem 1: package qt-creator-4.9.2-3.el8.x86_64 requires libclang.so.7()(64bit), but none of the providers can be installed
  - package qt-creator-4.9.2-3.el8.x86_64 requires libclang.so.7(LLVM_7)(64bit), but none of the providers can be installed
  - package qt-creator-4.9.2-3.el8.x86_64 requires libclangBasic.so.7()(64bit), but none of the providers can be installed
....

Comment 5 Dave Johansen 2019-12-06 15:36:41 UTC
Sorry but I'm no longer actively maintaining qt-creator

Comment 6 Fedora Update System 2019-12-06 22:32:25 UTC
FEDORA-EPEL-2019-92f3fc5671 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-92f3fc5671

Comment 7 Fedora Update System 2019-12-07 03:04:22 UTC
qt-creator-4.9.2-4.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-92f3fc5671


Note You need to log in before you can comment on or make changes to this bug.